ID CVE-2021-42374
Summary An out-of-bounds heap read in Busybox's unlzma applet leads to information leak and denial of service when crafted LZMA-compressed input is decompressed. This can be triggered by any applet/format that
References
Vulnerable Configurations
  • cpe:2.3:a:busybox:busybox:1.27.0:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.27.0:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.27.1:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.27.1:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.27.2:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.27.2:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.28.0:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.28.0:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.28.1:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.28.1:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.28.2:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.28.2:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.28.3:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.28.3:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.28.4:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.28.4:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.29.0:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.29.0:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.29.1:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.29.1:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.29.2:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.29.2:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.29.3:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.29.3:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.30.0:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.30.0:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.30.1:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.30.1:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.31.0:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.31.0:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.31.1:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.31.1:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.32.0:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.32.0:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.32.1:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.32.1:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.33.0:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.33.0:*:*:*:*:*:*:*
  • cpe:2.3:a:busybox:busybox:1.33.1:*:*:*:*:*:*:*
    cpe:2.3:a:busybox:busybox:1.33.1:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*
CVSS
Base: 3.3 (as of 29-11-2021 - 17:15)
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Infiltration of Hardware Development Environment
    An attacker, leveraging the ability to manipulate components of primary support systems and tools within the development and production environments, inserts malicious software within the hardware and/or firmware development environment. The infiltration purpose is to alter developed hardware components in a system destined for deployment at the victim's organization, for the purpose of disruption or further compromise.
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
LOCAL MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE PARTIAL
cvss-vector via4 AV:L/AC:M/Au:N/C:P/I:N/A:P
Last major update 29-11-2021 - 17:15
Published 15-11-2021 - 21:15
Last modified 29-11-2021 - 17:15
Back to Top