ID CVE-2019-7572
Summary SDL (Simple DirectMedia Layer) through 1.2.15 and 2.x through 2.0.9 has a buffer over-read in IMA_ADPCM_nibble in audio/SDL_wave.c.
References
Vulnerable Configurations
  • cpe:2.3:a:libsdl:simple_directmedia_layer:*:*:*:*:*:*:*:*
    cpe:2.3:a:libsdl:simple_directmedia_layer:*:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
  • cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:*
    cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:*
  • cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:*
    cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:*
CVSS
Base: 6.8 (as of 10-09-2019 - 03:15)
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:P/I:P/A:P
refmap via4
misc
mlist
  • [debian-lts-announce] 20190313 [SECURITY] [DLA 1713-1] libsdl1.2 security update
  • [debian-lts-announce] 20190313 [SECURITY] [DLA 1714-1] libsdl2 security update
suse
  • openSUSE-SU-2019:1213
  • openSUSE-SU-2019:1223
  • openSUSE-SU-2019:1261
Last major update 10-09-2019 - 03:15
Published 07-02-2019 - 07:29
Back to Top