ID CVE-2018-16890
Summary libcurl versions from 7.36.0 to before 7.64.0 is vulnerable to a heap buffer out-of-bounds read. The function handling incoming NTLM type-2 messages (`lib/vauth/ntlm.c:ntlm_decode_type2_target`) does not validate incoming data correctly and is subject to an integer overflow vulnerability. Using that overflow, a malicious or broken NTLM server could trick libcurl to accept a bad length + offset combination that would lead to a buffer read out-of-bounds.
References
Vulnerable Configurations
  • cpe:2.3:a:haxx:libcurl:7.36.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.36.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.37.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.37.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.37.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.37.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.38.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.38.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.39:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.39:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.39.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.39.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.40.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.40.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.41.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.41.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.42:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.42:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.42.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.42.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.42.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.42.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.43.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.43.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.44.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.44.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.45.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.45.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.46.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.46.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.47.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.47.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.47.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.47.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.48.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.48.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.49.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.49.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.49.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.49.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.50.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.50.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.50.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.50.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.50.2:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.50.2:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.50.3:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.50.3:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.51.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.51.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.52.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.52.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.52.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.52.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.53.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.53.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.53.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.53.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.54.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.54.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.54.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.54.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.55.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.55.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.55.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.55.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.56.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.56.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.56.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.56.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.57.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.57.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.58.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.58.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.59.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.59.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.60.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.60.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.61.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.61.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.61.1:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.61.1:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.62.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.62.0:*:*:*:*:*:*:*
  • cpe:2.3:a:haxx:libcurl:7.63.0:*:*:*:*:*:*:*
    cpe:2.3:a:haxx:libcurl:7.63.0:*:*:*:*:*:*:*
  • cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
    cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*
    cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
    cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
  • cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:*
    cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
  • cpe:2.3:o:netapp:clustered_data_ontap:*:*:*:*:*:*:*:*
    cpe:2.3:o:netapp:clustered_data_ontap:*:*:*:*:*:*:*:*
  • cpe:2.3:a:siemens:sinema_remote_connect_client:*:*:*:*:*:*:*:*
    cpe:2.3:a:siemens:sinema_remote_connect_client:*:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:communications_operations_monitor:3.4:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:communications_operations_monitor:3.4:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:communications_operations_monitor:4.0:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:communications_operations_monitor:4.0:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:http_server:12.2.1.3.0:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:http_server:12.2.1.3.0:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:secure_global_desktop:5.4:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:secure_global_desktop:5.4:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 23-07-2019 - 23:15)
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:P
refmap via4
bid 106947
confirm
debian DSA-4386
misc
mlist [infra-devnull] 20190404 [GitHub] [incubator-openwhisk-runtime-ballerina] falkzoll commented on issue #15: Update to new base image jdk8u202-b08_openj9-0.12.1.
ubuntu USN-3882-1
Last major update 23-07-2019 - 23:15
Published 06-02-2019 - 20:29
Back to Top