ID CVE-2021-31684
Summary A vulnerability was discovered in the indexOf function of JSONParserByteArray in JSON Smart versions 1.3 and 2.4 which causes a denial of service (DOS) via a crafted web request.
References
Vulnerable Configurations
  • cpe:2.3:a:json_smart_project:json_smart:1.3:*:*:*:*:*:*:*
    cpe:2.3:a:json_smart_project:json_smart:1.3:*:*:*:*:*:*:*
  • cpe:2.3:a:json_smart_project:json_smart:2.4:*:*:*:*:*:*:*
    cpe:2.3:a:json_smart_project:json_smart:2.4:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 10-06-2021 - 20:40)
Impact:
Exploitability:
CWE CWE-787
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:P
Last major update 10-06-2021 - 20:40
Published 01-06-2021 - 20:15
Last modified 10-06-2021 - 20:40
Back to Top