ID CVE-2020-2258
Summary Jenkins Health Advisor by CloudBees Plugin 3.2.0 and earlier does not correctly perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to view that HTTP endpoint.
References
Vulnerable Configurations
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.0:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.0:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.1:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.1:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.2:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.2:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.3:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.3:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.4:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.4:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.5:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:1.5:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:2.10:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:2.10:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:2.11:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:2.11:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.0:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.0:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.0.1:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.0.1:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.0.2:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.0.2:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.1.0:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.1.0:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.1.1:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.1.1:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.2.0:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:health_advisor_by_cloudbees:3.2.0:*:*:*:*:jenkins:*:*
CVSS
Base: 4.0 (as of 18-09-2020 - 13:20)
Impact:
Exploitability:
CWE CWE-863
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW SINGLE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
cvss-vector via4 AV:N/AC:L/Au:S/C:P/I:N/A:N
refmap via4
confirm https://www.jenkins.io/security/advisory/2020-09-16/#SECURITY-1998
mlist [oss-security] 20200916 Multiple vulnerabilities in Jenkins plugins
Last major update 18-09-2020 - 13:20
Published 16-09-2020 - 14:15
Last modified 18-09-2020 - 13:20
Back to Top