ID CVE-2009-3720
Summary The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.
References
Vulnerable Configurations
  • cpe:2.3:a:james_clark:expat:2.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:james_clark:expat:2.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:a_m_kuchling:pyxml:*:*:*:*:*:*:*:*
    cpe:2.3:a:a_m_kuchling:pyxml:*:*:*:*:*:*:*:*
  • cpe:2.3:a:python:python:*:*:*:*:*:*:*:*
    cpe:2.3:a:python:python:*:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 19-09-2017 - 01:29)
Impact:
Exploitability:
CWE NVD-CWE-noinfo
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:P
oval via4
  • accepted 2013-04-29T04:10:49.340-04:00
    class vulnerability
    contributors
    • name Aharon Chernin
      organization SCAP.com, LLC
    • name Dragos Prisaca
      organization G2, Inc.
    definition_extensions
    • comment The operating system installed on the system is Red Hat Enterprise Linux 3
      oval oval:org.mitre.oval:def:11782
    • comment CentOS Linux 3.x
      oval oval:org.mitre.oval:def:16651
    • comment The operating system installed on the system is Red Hat Enterprise Linux 4
      oval oval:org.mitre.oval:def:11831
    • comment CentOS Linux 4.x
      oval oval:org.mitre.oval:def:16636
    • comment Oracle Linux 4.x
      oval oval:org.mitre.oval:def:15990
    • comment The operating system installed on the system is Red Hat Enterprise Linux 5
      oval oval:org.mitre.oval:def:11414
    • comment The operating system installed on the system is CentOS Linux 5.x
      oval oval:org.mitre.oval:def:15802
    • comment Oracle Linux 5.x
      oval oval:org.mitre.oval:def:15459
    description The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.
    family unix
    id oval:org.mitre.oval:def:11019
    status accepted
    submitted 2010-07-09T03:56:16-04:00
    title The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.
    version 24
  • accepted 2015-04-20T04:00:31.996-04:00
    class vulnerability
    contributors
    • name Yamini Mohan R
      organization Hewlett-Packard
    • name Sushant Kumar Singh
      organization Hewlett-Packard
    • name Sushant Kumar Singh
      organization Hewlett-Packard
    • name Prashant Kumar
      organization Hewlett-Packard
    • name Mike Cokus
      organization The MITRE Corporation
    description The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.
    family unix
    id oval:org.mitre.oval:def:12719
    status accepted
    submitted 2011-07-28T14:46:10.000-05:00
    title HP-UX Apache Web Server, Remote Information Disclosure, Cross-Site Scripting (XSS), Denial of Service (DoS)
    version 46
  • accepted 2014-01-20T04:01:32.393-05:00
    class vulnerability
    contributors
    • name J. Daniel Brown
      organization DTCC
    • name Chris Coffin
      organization The MITRE Corporation
    definition_extensions
    comment VMware ESX Server 4.0 is installed
    oval oval:org.mitre.oval:def:6293
    description The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.
    family unix
    id oval:org.mitre.oval:def:7112
    status accepted
    submitted 2010-06-01T17:30:00.000-05:00
    title Expat UTF-8 Character XML Parsing Remote Denial of Service Vulnerability
    version 8
redhat via4
advisories
  • bugzilla
    id 531697
    title CVE-2009-3720 expat: buffer over-read and crash on XML with malformed UTF-8 sequences
    oval
    OR
    • AND
      • comment Red Hat Enterprise Linux 3 is installed
        oval oval:com.redhat.rhba:tst:20070026001
      • comment 4Suite is earlier than 0:0.11.1-15
        oval oval:com.redhat.rhsa:tst:20091572002
      • comment 4Suite is signed with Red Hat master key
        oval oval:com.redhat.rhsa:tst:20091572003
    • AND
      • comment Red Hat Enterprise Linux 4 is installed
        oval oval:com.redhat.rhba:tst:20070304001
      • comment 4Suite is earlier than 0:1.0-3.el4_8.1
        oval oval:com.redhat.rhsa:tst:20091572005
      • comment 4Suite is signed with Red Hat master key
        oval oval:com.redhat.rhsa:tst:20091572003
    rhsa
    id RHSA-2009:1572
    released 2009-11-10
    severity Moderate
    title RHSA-2009:1572: 4Suite security update (Moderate)
  • bugzilla
    id 533174
    title CVE-2009-3560 expat: buffer over-read and crash in big2_toUtf8() on XML with malformed UTF-8 sequences
    oval
    OR
    • AND
      • comment Red Hat Enterprise Linux 3 is installed
        oval oval:com.redhat.rhba:tst:20070026001
      • OR
        • AND
          • comment expat is earlier than 0:1.95.5-6.2
            oval oval:com.redhat.rhsa:tst:20091625002
          • comment expat is signed with Red Hat master key
            oval oval:com.redhat.rhsa:tst:20091625003
        • AND
          • comment expat-devel is earlier than 0:1.95.5-6.2
            oval oval:com.redhat.rhsa:tst:20091625004
          • comment expat-devel is signed with Red Hat master key
            oval oval:com.redhat.rhsa:tst:20091625005
    • AND
      • comment Red Hat Enterprise Linux 4 is installed
        oval oval:com.redhat.rhba:tst:20070304001
      • OR
        • AND
          • comment expat is earlier than 0:1.95.7-4.el4_8.2
            oval oval:com.redhat.rhsa:tst:20091625007
          • comment expat is signed with Red Hat master key
            oval oval:com.redhat.rhsa:tst:20091625003
        • AND
          • comment expat-devel is earlier than 0:1.95.7-4.el4_8.2
            oval oval:com.redhat.rhsa:tst:20091625008
          • comment expat-devel is signed with Red Hat master key
            oval oval:com.redhat.rhsa:tst:20091625005
    • AND
      • comment Red Hat Enterprise Linux 5 is installed
        oval oval:com.redhat.rhba:tst:20070331001
      • OR
        • AND
          • comment expat is earlier than 0:1.95.8-8.3.el5_4.2
            oval oval:com.redhat.rhsa:tst:20091625010
          • comment expat is signed with Red Hat redhatrelease key
            oval oval:com.redhat.rhsa:tst:20091625011
        • AND
          • comment expat-devel is earlier than 0:1.95.8-8.3.el5_4.2
            oval oval:com.redhat.rhsa:tst:20091625012
          • comment expat-devel is signed with Red Hat redhatrelease key
            oval oval:com.redhat.rhsa:tst:20091625013
    rhsa
    id RHSA-2009:1625
    released 2009-12-07
    severity Moderate
    title RHSA-2009:1625: expat security update (Moderate)
  • bugzilla
    id 531697
    title CVE-2009-3720 expat: buffer over-read and crash on XML with malformed UTF-8 sequences
    oval
    OR
    • AND
      • comment Red Hat Enterprise Linux 4 is installed
        oval oval:com.redhat.rhba:tst:20070304001
      • comment PyXML is earlier than 0:0.8.3-6.el4_8.2
        oval oval:com.redhat.rhsa:tst:20100002002
      • comment PyXML is signed with Red Hat master key
        oval oval:com.redhat.rhsa:tst:20100002003
    • AND
      • comment Red Hat Enterprise Linux 5 is installed
        oval oval:com.redhat.rhba:tst:20070331001
      • comment PyXML is earlier than 0:0.8.4-4.el5_4.2
        oval oval:com.redhat.rhsa:tst:20100002005
      • comment PyXML is signed with Red Hat redhatrelease key
        oval oval:com.redhat.rhsa:tst:20100002006
    rhsa
    id RHSA-2010:0002
    released 2010-01-04
    severity Moderate
    title RHSA-2010:0002: PyXML security update (Moderate)
  • rhsa
    id RHSA-2011:0896
rpms
  • 4Suite-0:0.11.1-15
  • 4Suite-0:1.0-3.el4_8.1
  • expat-0:1.95.5-6.2
  • expat-devel-0:1.95.5-6.2
  • expat-0:1.95.7-4.el4_8.2
  • expat-devel-0:1.95.7-4.el4_8.2
  • expat-0:1.95.8-8.3.el5_4.2
  • expat-devel-0:1.95.8-8.3.el5_4.2
  • PyXML-0:0.8.3-6.el4_8.2
  • PyXML-0:0.8.4-4.el5_4.2
  • python-0:2.3.4-14.10.el4
  • python-devel-0:2.3.4-14.10.el4
  • python-docs-0:2.3.4-14.10.el4
  • python-tools-0:2.3.4-14.10.el4
  • tkinter-0:2.3.4-14.10.el4
  • python-0:2.4.3-44.el5
  • python-devel-0:2.4.3-44.el5
  • python-libs-0:2.4.3-44.el5
  • python-tools-0:2.4.3-44.el5
  • tkinter-0:2.4.3-44.el5
refmap via4
confirm
fedora
  • FEDORA-2009-12690
  • FEDORA-2009-12737
  • FEDORA-2009-12753
  • FEDORA-2010-17720
  • FEDORA-2010-17732
  • FEDORA-2010-17762
  • FEDORA-2010-17807
  • FEDORA-2010-17819
hp HPSBUX02645
mandriva
  • MDVSA-2009:211
  • MDVSA-2009:212
  • MDVSA-2009:215
  • MDVSA-2009:216
  • MDVSA-2009:217
  • MDVSA-2009:218
  • MDVSA-2009:219
  • MDVSA-2009:220
misc http://sourceforge.net/tracker/index.php?func=detail&aid=1990430&group_id=10127&atid=110127
mlist
  • [expat-bugs] 20090117 [ expat-Bugs-1990430 ] Parser crash with specially formatted UTF-8 sequences
  • [oss-security] 20090821 expat bug 1990430
  • [oss-security] 20090826 Re: Re: expat bug 1990430
  • [oss-security] 20090826 Re: expat bug 1990430
  • [oss-security] 20090827 Re: Re: expat bug 1990430
  • [oss-security] 20090906 Re: Re: expat bug 1990430
  • [oss-security] 20091022 Re: Re: Regarding expat bug 1990430
  • [oss-security] 20091022 Re: Regarding expat bug 1990430
  • [oss-security] 20091022 Regarding expat bug 1990430
  • [oss-security] 20091023 Re: CVE Request -- expat [was: Re: Regarding expat bug 1990430]
  • [oss-security] 20091026 Re: CVE Request -- expat [was: Re: Regarding expat bug 1990430]
  • [oss-security] 20091028 Re: CVE Request -- expat [was: Re: Regarding expat bug 1990430]
  • [security-announce] 20100303 VMSA-2010-0004 ESX Service Console and vMA third party updates
sectrack 1023160
secunia
  • 37324
  • 37537
  • 37925
  • 38050
  • 38231
  • 38794
  • 38832
  • 38834
  • 39478
  • 41701
  • 42326
  • 42338
  • 43300
slackware SSA:2011-041-02
sunalert 273630
suse
  • SUSE-SR:2009:018
  • SUSE-SR:2010:011
  • SUSE-SR:2010:012
  • SUSE-SR:2010:013
  • SUSE-SR:2010:014
ubuntu
  • USN-890-1
  • USN-890-6
vupen
  • ADV-2010-0528
  • ADV-2010-0896
  • ADV-2010-1107
  • ADV-2010-3035
  • ADV-2010-3053
  • ADV-2010-3061
  • ADV-2011-0359
statements via4
contributor Tomas Hoger
lastmodified 2010-03-05
organization Red Hat
statement Red Hat is aware of this issue and is tracking it via the following bug: https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2009-3720 The Red Hat Security Response Team has rated this issue as having moderate security impact in Python, a future update may address this flaw. If a system has PyXML installed, Python will use PyXML for expat-related functions and is then not vulnerable to the issue.
Last major update 19-09-2017 - 01:29
Published 03-11-2009 - 16:30
Back to Top