ID CVE-2021-3476
Summary A flaw was found in OpenEXR's B44 uncompression functionality in versions before 3.0.0-beta. An attacker who is able to submit a crafted file to OpenEXR could trigger shift overflows, potentially affecting application availability.
References
Vulnerable Configurations
  • cpe:2.3:a:openexr:openexr:-:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:-:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.0:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.0.5:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.0.5:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.0.6:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.0.6:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.0.7:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.0.7:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.1.0:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.2.2:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.3.0:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.3.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.3.1:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.3.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.3.2:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.3.2:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.4.0:-:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.4.0:-:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.4.0:alpha:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.4.0:alpha:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.7.0:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.7.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:1.7.1:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:1.7.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.0.0:-:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.0.0:-:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.0.0:beta1:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.0.0:beta1:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.0.0:beta2:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.0.0:beta2:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.1.0:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.2.0:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.2.2:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.3.0:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.3.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.4.0:-:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.4.0:-:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.4.0:beta1:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.4.0:beta1:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.4.1:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.4.2:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.4.2:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.5.0:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.5.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.5.2:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.5.2:*:*:*:*:*:*:*
  • cpe:2.3:a:openexr:openexr:2.5.3:*:*:*:*:*:*:*
    cpe:2.3:a:openexr:openexr:2.5.3:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 11-07-2021 - 04:15)
Impact:
Exploitability:
CWE CWE-190
CAPEC
  • Forced Integer Overflow
    This attack forces an integer variable to go out of range. The integer variable is often used as an offset such as size of memory allocation or similarly. The attacker would typically control the value of such variable and try to get it out of range. For instance the integer in question is incremented past the maximum possible value, it may wrap to become a very small, or negative number, therefore providing a very incorrect value which can lead to unexpected behavior. At worst the attacker can execute arbitrary code.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:P
Last major update 11-07-2021 - 04:15
Published 30-03-2021 - 18:15
Last modified 11-07-2021 - 04:15
Back to Top