ID CVE-2017-5845
Summary The gst_avi_demux_parse_ncdt function in gst/avi/gstavidemux.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via a ncdt sub-tag that "goes behind" the surrounding tag.
References
Vulnerable Configurations
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.0:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.0:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.1:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.1:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.2:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.2:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.3:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.3:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.4:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.4:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.5:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.5:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.6:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.6:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.7:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.7:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.8:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.8:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.9:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.9:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.10:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.10:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.11:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.11:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.12:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.12:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.13:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.13:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.14:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.14:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.15:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.15:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.16:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.16:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.17:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.17:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.18:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.18:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.19:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.19:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.20:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.20:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.21:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.21:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.22:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.22:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.23:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.23:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.24:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.24:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.25:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.25:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.26:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.26:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.27:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.27:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.28:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.28:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.29:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.29:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.30:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.30:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.31:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.31:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.32:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.32:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.33:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.33:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.34:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.34:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.35:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.35:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:0.10.36:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:0.10.36:*:*:*:*:*:*:*
  • cpe:2.3:a:gstreamer_project:gstreamer:1.10.2:*:*:*:*:*:*:*
    cpe:2.3:a:gstreamer_project:gstreamer:1.10.2:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 05-01-2018 - 02:31)
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:P
redhat via4
advisories
rhsa
id RHSA-2017:2060
rpms
  • orc-0:0.4.26-1.el7
  • orc-compiler-0:0.4.26-1.el7
  • orc-devel-0:0.4.26-1.el7
  • orc-doc-0:0.4.26-1.el7
  • gstreamer-plugins-good-0:0.10.31-13.el7
  • gstreamer-plugins-good-devel-docs-0:0.10.31-13.el7
  • gstreamer-plugins-bad-free-0:0.10.23-23.el7
  • gstreamer-plugins-bad-free-devel-0:0.10.23-23.el7
  • gstreamer-plugins-bad-free-devel-docs-0:0.10.23-23.el7
  • clutter-gst2-0:2.0.18-1.el7
  • clutter-gst2-devel-0:2.0.18-1.el7
  • gnome-video-effects-0:0.4.3-1.el7
  • gstreamer1-plugins-base-0:1.10.4-1.el7
  • gstreamer1-plugins-base-devel-0:1.10.4-1.el7
  • gstreamer1-plugins-base-devel-docs-0:1.10.4-1.el7
  • gstreamer1-plugins-base-tools-0:1.10.4-1.el7
  • gstreamer1-0:1.10.4-2.el7
  • gstreamer1-devel-0:1.10.4-2.el7
  • gstreamer1-devel-docs-0:1.10.4-2.el7
  • gstreamer1-plugins-good-0:1.10.4-2.el7
  • gstreamer1-plugins-bad-free-0:1.10.4-2.el7
  • gstreamer1-plugins-bad-free-devel-0:1.10.4-2.el7
  • gstreamer1-plugins-bad-free-gtk-0:1.10.4-2.el7
refmap via4
bid 96001
confirm
debian DSA-3820
gentoo GLSA-201705-10
mlist
  • [oss-security] 20170201 Multiple memory access issues in gstreamer
  • [oss-security] 20170202 Re: Multiple memory access issues in gstreamer
Last major update 05-01-2018 - 02:31
Published 09-02-2017 - 15:59
Back to Top