ID CVE-2017-11410
Summary In Wireshark through 2.0.13 and 2.2.x through 2.2.7, the WBXML dissector could go into an infinite loop, triggered by packet injection or a malformed capture file. This was addressed in epan/dissectors/packet-wbxml.c by adding validation of the relationships between indexes and lengths. NOTE: this vulnerability exists because of an incomplete fix for CVE-2017-7702.
References
Vulnerable Configurations
  • cpe:2.3:a:wireshark:wireshark:2.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.5:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.5:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.6:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.6:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.7:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.7:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.8:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.8:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.9:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.9:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.10:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.10:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.11:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.11:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.12:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.12:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.0.13:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.0.13:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.2.0:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.2.2:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.2.3:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.2.4:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.2.4:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.2.5:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.2.6:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.2.6:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.2.7:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.2.7:*:*:*:*:*:*:*
CVSS
Base: 7.8 (as of 03-10-2019 - 00:03)
Impact:
Exploitability:
CWE CWE-835
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE COMPLETE
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:C
refmap via4
confirm
Last major update 03-10-2019 - 00:03
Published 18-07-2017 - 21:29
Back to Top