ID CVE-2011-4100
Summary The csnStreamDissector function in epan/dissectors/packet-csn1.c in the CSN.1 dissector in Wireshark 1.6.x before 1.6.3 does not initialize a certain variable, which allows remote attackers to cause a denial of service (application crash) via a malformed packet.
References
Vulnerable Configurations
  • cpe:2.3:a:wireshark:wireshark:1.6.0:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:1.6.0:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:1.6.1:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:1.6.1:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:1.6.2:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:1.6.2:*:*:*:*:*:*:*
CVSS
Base: 4.3 (as of 19-09-2017 - 01:34)
Impact:
Exploitability:
CWE CWE-399
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:N/I:N/A:P
oval via4
accepted 2013-08-19T04:00:38.979-04:00
class vulnerability
contributors
  • name Shane Shaffer
    organization G2, Inc.
  • name Shane Shaffer
    organization G2, Inc.
  • name Shane Shaffer
    organization G2, Inc.
definition_extensions
comment Wireshark is installed on the system.
oval oval:org.mitre.oval:def:6589
description The csnStreamDissector function in epan/dissectors/packet-csn1.c in the CSN.1 dissector in Wireshark 1.6.x before 1.6.3 does not initialize a certain variable, which allows remote attackers to cause a denial of service (application crash) via a malformed packet.
family windows
id oval:org.mitre.oval:def:14833
status accepted
submitted 2012-02-27T15:34:33.178-04:00
title CSN.1 dissector in Wireshark 1.6.x before 1.6.3 denial of service vulnerability
version 8
refmap via4
bid 50479
confirm
mlist [oss-security] 20111101 Re: CVE request for wireshark flaws
osvdb 76768
secunia 46644
xf wireshark-csn1-dissector-dos(71090)
Last major update 19-09-2017 - 01:34
Published 03-11-2011 - 15:55
Back to Top