ID CVE-2021-42260
Summary TinyXML through 2.6.2 has an infinite loop in TiXmlParsingData::Stamp in tinyxmlparser.cpp via the TIXML_UTF_LEAD_0 case. It can be triggered by a crafted XML message and leads to a denial of service.
References
Vulnerable Configurations
  • cpe:2.3:a:tinyxml_project:tinyxml:2.3.0:beta:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.3.0:beta:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.3.1:beta:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.3.1:beta:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.3.2:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.3.2:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.3.3:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.3.3:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.3.4:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.3.4:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.4.0:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.4.0:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.4.1:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.4.2:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.4.2:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.4.3:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.4.3:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.5.0:beta:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.5.0:beta:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.5.2:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.5.2:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.5.3:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.5.3:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.6.0:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.6.0:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.6.1:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.6.1:*:*:*:*:*:*:*
  • cpe:2.3:a:tinyxml_project:tinyxml:2.6.2:*:*:*:*:*:*:*
    cpe:2.3:a:tinyxml_project:tinyxml:2.6.2:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 12-05-2022 - 20:02)
Impact:
Exploitability:
CWE CWE-835
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:P
Last major update 12-05-2022 - 20:02
Published 11-10-2021 - 20:15
Last modified 12-05-2022 - 20:02
Back to Top