ID CVE-2019-2778
Summary Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Security: Privileges). Supported versions that are affected are 5.7.26 and prior and 8.0.16 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data and unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Server. CVSS 3.0 Base Score 5.4 (Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L).
References
Vulnerable Configurations
  • cpe:2.3:a:oracle:mysql:5.7.0:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.0:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.0:*:*:*:-:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.0:*:*:*:-:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.0:*:*:*:community:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.0:*:*:*:community:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.0:*:*:*:enterprise:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.0:*:*:*:enterprise:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.1:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.1:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.2:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.2:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.3:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.3:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.4:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.4:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.5:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.5:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.6:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.6:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.7:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.7:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.8:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.8:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.9:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.9:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.10:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.10:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.11:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.11:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.12:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.12:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.13:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.13:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.14:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.14:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.15:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.15:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.16:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.16:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.17:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.17:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.18:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.18:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.19:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.19:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.20:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.20:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.21:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.21:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.22:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.22:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.23:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.23:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.24:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.24:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.25:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.25:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:5.7.26:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:5.7.26:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.5:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.5:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.10:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.10:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.11:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.11:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.12:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.12:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.13:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.13:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.14:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.14:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.15:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.15:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:mysql:8.0.16:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:mysql:8.0.16:*:*:*:*:*:*:*
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*
    cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
    cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
  • cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:*
    cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:*
CVSS
Base: 5.5 (as of 24-08-2020 - 17:37)
Impact:
Exploitability:
CWE NVD-CWE-noinfo
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW SINGLE
Impact
ConfidentialityIntegrityAvailability
NONE PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:L/Au:S/C:N/I:P/A:P
redhat via4
advisories
  • rhsa
    id RHSA-2019:2484
  • rhsa
    id RHSA-2019:2511
rpms
  • rh-mysql80-mysql-0:8.0.17-1.el7
  • rh-mysql80-mysql-common-0:8.0.17-1.el7
  • rh-mysql80-mysql-config-0:8.0.17-1.el7
  • rh-mysql80-mysql-config-syspaths-0:8.0.17-1.el7
  • rh-mysql80-mysql-debuginfo-0:8.0.17-1.el7
  • rh-mysql80-mysql-devel-0:8.0.17-1.el7
  • rh-mysql80-mysql-errmsg-0:8.0.17-1.el7
  • rh-mysql80-mysql-server-0:8.0.17-1.el7
  • rh-mysql80-mysql-server-syspaths-0:8.0.17-1.el7
  • rh-mysql80-mysql-syspaths-0:8.0.17-1.el7
  • rh-mysql80-mysql-test-0:8.0.17-1.el7
  • mecab-0:0.996-1.module+el8.0.0+3898+e09bb8de.9
  • mecab-debuginfo-0:0.996-1.module+el8.0.0+3898+e09bb8de.9
  • mecab-debugsource-0:0.996-1.module+el8.0.0+3898+e09bb8de.9
  • mecab-ipadic-0:2.7.0.20070801-16.module+el8.0.0+3898+e09bb8de
  • mecab-ipadic-EUCJP-0:2.7.0.20070801-16.module+el8.0.0+3898+e09bb8de
  • mysql-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-common-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-debuginfo-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-debugsource-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-devel-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-devel-debuginfo-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-errmsg-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-libs-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-libs-debuginfo-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-server-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-server-debuginfo-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-test-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
  • mysql-test-debuginfo-0:8.0.17-3.module+el8.0.0+3898+e09bb8de
refmap via4
confirm
fedora
  • FEDORA-2019-96516ce0ac
  • FEDORA-2019-c106e46a95
misc http://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
ubuntu USN-4070-1
Last major update 24-08-2020 - 17:37
Published 23-07-2019 - 23:15
Last modified 24-08-2020 - 17:37
Back to Top