ID CVE-2017-11292
Summary Adobe Flash Player version 27.0.0.159 and earlier has a flawed bytecode verification procedure, which allows for an untrusted value to be used in the calculation of an array index. This can lead to type confusion, and successful exploitation could lead to arbitrary code execution.
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:flash_player:27.0.0.159
    cpe:2.3:a:adobe:flash_player:27.0.0.159
  • Apple Mac OS
    cpe:2.3:o:apple:mac_os
  • Linux Kernel
    cpe:2.3:o:linux:linux_kernel
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
  • cpe:2.3:a:adobe:flash_player:27.0.0.130:-:-:-:-:edge
    cpe:2.3:a:adobe:flash_player:27.0.0.130:-:-:-:-:edge
  • cpe:2.3:a:adobe:flash_player:27.0.0.130:-:-:-:-:internet_explorer_11
    cpe:2.3:a:adobe:flash_player:27.0.0.130:-:-:-:-:internet_explorer_11
  • cpe:2.3:o:microsoft:windows_10
    cpe:2.3:o:microsoft:windows_10
  • cpe:2.3:o:microsoft:windows_8.1
    cpe:2.3:o:microsoft:windows_8.1
  • cpe:2.3:a:adobe:flash_player:27.0.0.159:-:-:-:-:chrome
    cpe:2.3:a:adobe:flash_player:27.0.0.159:-:-:-:-:chrome
  • Apple Mac OS X
    cpe:2.3:o:apple:mac_os_x
  • cpe:2.3:o:google:chrome_os
    cpe:2.3:o:google:chrome_os
  • Linux Kernel
    cpe:2.3:o:linux:linux_kernel
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
CVSS
Base: 6.5
Impact:
Exploitability:
CWE CWE-129
CAPEC
  • Overflow Buffers
    Buffer Overflow attacks target improper or missing bounds checking on buffer operations, typically triggered by input injected by an attacker. As a consequence, an attacker is able to write past the boundaries of allocated buffer regions in memory, causing a program crash or potentially redirection of execution as per the attackers' choice.
nessus via4
  • NASL family FreeBSD Local Security Checks
    NASL id FREEBSD_PKG_A73518DAB2FA11E798EFD43D7EF03AA6.NASL
    description Adobe reports : - This update resolves a type confusion vulnerability that could lead to remote code execution (CVE-2017-11292).
    last seen 2018-09-01
    modified 2018-01-31
    plugin id 103860
    published 2017-10-17
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=103860
    title FreeBSD : Flash Player -- Remote code execution (a73518da-b2fa-11e7-98ef-d43d7ef03aa6)
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-201710-22.NASL
    description The remote host is affected by the vulnerability described in GLSA-201710-22 (Adobe Flash Player: Remote execution of arbitrary code) A critical type confusion vulnerability was discovered in Adobe Flash Player. Impact : A remote attacker could execute arbitrary code. Workaround : There is no known workaround at this time.
    last seen 2018-09-01
    modified 2018-01-26
    plugin id 104065
    published 2017-10-23
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=104065
    title GLSA-201710-22 : Adobe Flash Player: Remote execution of arbitrary code
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2017-2899.NASL
    description An update for flash-plugin is now available for Red Hat Enterprise Linux 6 Supplementary. Red Hat Product Security has rated this update as having a security impact of Critical. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section. The flash-plugin package contains a Mozilla Firefox compatible Adobe Flash Player web browser plug-in. This update upgrades Flash Player to version 27.0.0.170. Security Fix(es) : * This update fixes one vulnerability in Adobe Flash Player. This vulnerability, detailed in the Adobe Security Bulletin listed in the References section, could allow an attacker to create a specially crafted SWF file that would cause flash-plugin to crash, execute arbitrary code, or disclose sensitive information when the victim loaded a page containing the malicious SWF content. (CVE-2017-11292)
    last seen 2018-09-01
    modified 2018-07-30
    plugin id 103915
    published 2017-10-18
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=103915
    title RHEL 6 : flash-plugin (RHSA-2017:2899)
  • NASL family Windows
    NASL id FLASH_PLAYER_APSB17-32.NASL
    description The version of Adobe Flash Player installed on the remote Windows host is equal or prior to version 27.0.0.159. It is, therefore, affected by an unspecified type confusion flaw that is caused by input not being properly validated. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a website containing specially crafted Flash content, to trigger the vulnerability and potentially execute arbitrary code.
    last seen 2018-09-01
    modified 2018-07-11
    plugin id 103922
    published 2017-10-18
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=103922
    title Adobe Flash Player <= 27.0.0.159 Type Confusion Vulnerability (APSB17-32)
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_FLASH_PLAYER_APSB17-32.NASL
    description The version of Adobe Flash Player installed on the remote macOS or Mac OS X host is equal or prior to version 27.0.0.159. It is, therefore, affected by an unspecified type confusion flaw that is caused by input not being properly validated. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a website containing specially crafted Flash content, to trigger the vulnerability and potentially execute arbitrary code.
    last seen 2018-09-01
    modified 2018-07-14
    plugin id 103923
    published 2017-10-18
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=103923
    title Adobe Flash Player for Mac <= 27.0.0.159 Multiple Vulnerabilities (APSB17-32)
  • NASL family Windows : Microsoft Bulletins
    NASL id SMB_NT_MS17_OCT_4049179.NASL
    description The remote Windows host is missing security update KB4049179. It is, therefore, affected by an unspecified type confusion flaw that is caused by input not being properly validated. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a website containing specially crafted Flash content, to trigger the vulnerability and potentially execute arbitrary code.
    last seen 2018-09-02
    modified 2018-07-30
    plugin id 103924
    published 2017-10-18
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=103924
    title KB4049179: Security update for Adobe Flash Player (October 2017)
redhat via4
advisories
rhsa
id RHSA-2017:2899
refmap via4
bid 101286
confirm https://helpx.adobe.com/security/products/flash-player/apsb17-32.html
gentoo GLSA-201710-22
sectrack 1039582
the hacker news via4
id THN:5AD427A8B33BDFD2EE553727C6CE4EE0
last seen 2018-01-27
modified 2017-10-16
published 2017-10-16
reporter Mohit Kumar
source https://thehackernews.com/2017/10/flash-player-zero-day.html
title Hackers Use New Flash Zero-Day Exploit to Distribute FinFisher Spyware
Last major update 22-10-2017 - 15:29
Published 22-10-2017 - 15:29
Last modified 07-12-2017 - 21:29
Back to Top