ID CVE-2013-0641
Summary Buffer overflow in Adobe Reader and Acrobat 9.x before 9.5.4, 10.x before 10.1.6, and 11.x before 11.0.02 allows remote attackers to execute arbitrary code via a crafted PDF document, as exploited in the wild in February 2013.
References
Vulnerable Configurations
  • Adobe Acrobat Reader 9.1.2
    cpe:2.3:a:adobe:acrobat_reader:9.1.2
  • Adobe Acrobat Reader 9.4.1
    cpe:2.3:a:adobe:acrobat_reader:9.4.1
  • Adobe Acrobat Reader 9.4.2
    cpe:2.3:a:adobe:acrobat_reader:9.4.2
  • Adobe Acrobat Reader 9.5.2
    cpe:2.3:a:adobe:acrobat_reader:9.5.2
  • Adobe Acrobat Reader 9.1.3
    cpe:2.3:a:adobe:acrobat_reader:9.1.3
  • Adobe Acrobat Reader 9.1
    cpe:2.3:a:adobe:acrobat_reader:9.1
  • Adobe Acrobat Reader 9.4.7
    cpe:2.3:a:adobe:acrobat_reader:9.4.7
  • Adobe Acrobat Reader 9.5.1
    cpe:2.3:a:adobe:acrobat_reader:9.5.1
  • Adobe Acrobat Reader 9.3.3
    cpe:2.3:a:adobe:acrobat_reader:9.3.3
  • Adobe Acrobat Reader 9.2
    cpe:2.3:a:adobe:acrobat_reader:9.2
  • Adobe Acrobat Reader 9.4.4
    cpe:2.3:a:adobe:acrobat_reader:9.4.4
  • Adobe Acrobat Reader 9.4.3
    cpe:2.3:a:adobe:acrobat_reader:9.4.3
  • Adobe Acrobat Reader 9.1.1
    cpe:2.3:a:adobe:acrobat_reader:9.1.1
  • Adobe Acrobat Reader 9.5
    cpe:2.3:a:adobe:acrobat_reader:9.5
  • Adobe Acrobat Reader 9.0
    cpe:2.3:a:adobe:acrobat_reader:9.0
  • Adobe Acrobat Reader 9.3.1
    cpe:2.3:a:adobe:acrobat_reader:9.3.1
  • Adobe Acrobat Reader 9.3
    cpe:2.3:a:adobe:acrobat_reader:9.3
  • Adobe Acrobat Reader 9.4
    cpe:2.3:a:adobe:acrobat_reader:9.4
  • Adobe Acrobat Reader 9.4.6
    cpe:2.3:a:adobe:acrobat_reader:9.4.6
  • Adobe Acrobat Reader 9.4.5
    cpe:2.3:a:adobe:acrobat_reader:9.4.5
  • Adobe Acrobat Reader 9.3.2
    cpe:2.3:a:adobe:acrobat_reader:9.3.2
  • Adobe Acrobat Reader 9.3.4
    cpe:2.3:a:adobe:acrobat_reader:9.3.4
  • Adobe Acrobat Reader 9.5.3
    cpe:2.3:a:adobe:acrobat_reader:9.5.3
  • Adobe Acrobat Reader X (10.1.2)
    cpe:2.3:a:adobe:acrobat_reader:10.1.2
  • Adobe Acrobat Reader X (10.0.1)
    cpe:2.3:a:adobe:acrobat_reader:10.0.1
  • Adobe Acrobat Reader X 10.1
    cpe:2.3:a:adobe:acrobat_reader:10.1
  • Adobe Acrobat Reader 10.1.5
    cpe:2.3:a:adobe:acrobat_reader:10.1.5
  • Adobe Acrobat Reader X (10.0.3)
    cpe:2.3:a:adobe:acrobat_reader:10.0.3
  • Adobe Acrobat Reader X 10.1.1
    cpe:2.3:a:adobe:acrobat_reader:10.1.1
  • Adobe Acrobat Reader X (10.0.2)
    cpe:2.3:a:adobe:acrobat_reader:10.0.2
  • Adobe Acrobat Reader X (10.1.3)
    cpe:2.3:a:adobe:acrobat_reader:10.1.3
  • Adobe Acrobat Reader X (10.1.4)
    cpe:2.3:a:adobe:acrobat_reader:10.1.4
  • Adobe Acrobat Reader X (10.0)
    cpe:2.3:a:adobe:acrobat_reader:10.0
  • Adobe Acrobat Reader XI (11.0.1)
    cpe:2.3:a:adobe:acrobat_reader:11.0.1
  • Adobe Acrobat Reader 11.0
    cpe:2.3:a:adobe:acrobat_reader:11.0
  • Adobe Acrobat 9.5.2
    cpe:2.3:a:adobe:acrobat:9.5.2
  • Adobe Acrobat 9.4.1
    cpe:2.3:a:adobe:acrobat:9.4.1
  • Adobe Acrobat 9.4.4
    cpe:2.3:a:adobe:acrobat:9.4.4
  • Adobe Acrobat 9.4.2
    cpe:2.3:a:adobe:acrobat:9.4.2
  • Adobe Acrobat 9.4.3
    cpe:2.3:a:adobe:acrobat:9.4.3
  • Adobe Acrobat 9.4.6
    cpe:2.3:a:adobe:acrobat:9.4.6
  • Adobe Acrobat 9.4.5
    cpe:2.3:a:adobe:acrobat:9.4.5
  • Adobe Acrobat 9.4.7
    cpe:2.3:a:adobe:acrobat:9.4.7
  • Adobe Acrobat 9.1
    cpe:2.3:a:adobe:acrobat:9.1
  • Adobe Acrobat 9.5.1
    cpe:2.3:a:adobe:acrobat:9.5.1
  • Adobe Acrobat 9.3.3
    cpe:2.3:a:adobe:acrobat:9.3.3
  • Adobe Acrobat 9.3 Professional
    cpe:2.3:a:adobe:acrobat:9.3:-:pro
  • Adobe Acrobat 9.1 Professional
    cpe:2.3:a:adobe:acrobat:9.1:-:pro
  • Adobe Acrobat 9.0 Professional
    cpe:2.3:a:adobe:acrobat:9.0:-:pro
  • Adobe Acrobat 9.2
    cpe:2.3:a:adobe:acrobat:9.2
  • Adobe Acrobat 9.5.3
    cpe:2.3:a:adobe:acrobat:9.5.3
  • cpe:2.3:a:adobe:acrobat:9.0
  • Adobe Acrobat 9.4.5
    cpe:2.3:a:adobe:acrobat:9.4.5
  • Adobe Acrobat 9.4.3
    cpe:2.3:a:adobe:acrobat:9.4.3
  • Adobe Acrobat 9.4.4
    cpe:2.3:a:adobe:acrobat:9.4.4
  • Adobe Acrobat 9.3
    cpe:2.3:a:adobe:acrobat:9.3
  • Adobe Acrobat 9.4.1
    cpe:2.3:a:adobe:acrobat:9.4.1
  • Adobe Acrobat 9.5
    cpe:2.3:a:adobe:acrobat:9.5
  • Adobe Acrobat 9.3.4
    cpe:2.3:a:adobe:acrobat:9.3.4
  • Adobe Acrobat 9.4.2
    cpe:2.3:a:adobe:acrobat:9.4.2
  • Adobe Acrobat 9.3.2
    cpe:2.3:a:adobe:acrobat:9.3.2
  • Adobe Acrobat 9.1.3
    cpe:2.3:a:adobe:acrobat:9.1.3
  • Adobe Acrobat 9.3.4
    cpe:2.3:a:adobe:acrobat:9.3.4
  • Adobe Acrobat 9.2
    cpe:2.3:a:adobe:acrobat:9.2
  • Adobe Acrobat 9.3.1
    cpe:2.3:a:adobe:acrobat:9.3.1
  • Adobe Acrobat 9.1.1
    cpe:2.3:a:adobe:acrobat:9.1.1
  • Adobe Acrobat 9.4
    cpe:2.3:a:adobe:acrobat:9.4
  • Adobe Acrobat 9.4.6
    cpe:2.3:a:adobe:acrobat:9.4.6
  • Adobe Acrobat 9.1.3
    cpe:2.3:a:adobe:acrobat:9.1.3
  • Adobe Acrobat 9.3.2
    cpe:2.3:a:adobe:acrobat:9.3.2
  • Adobe Acrobat 9.3.1
    cpe:2.3:a:adobe:acrobat:9.3.1
  • Adobe Acrobat 9.1.1
    cpe:2.3:a:adobe:acrobat:9.1.1
  • cpe:2.3:a:adobe:acrobat:9.1.2
  • Adobe Acrobat X (10.1.2)
    cpe:2.3:a:adobe:acrobat:10.1.2
  • Adobe Acrobat X (10.0.1)
    cpe:2.3:a:adobe:acrobat:10.0.1
  • Adobe Acrobat X (10.0)
    cpe:2.3:a:adobe:acrobat:10.0
  • Adobe Acrobat X (10.1.4)
    cpe:2.3:a:adobe:acrobat:10.1.4
  • Adobe Acrobat X Professional
    cpe:2.3:a:adobe:acrobat:10.0:-:pro
  • Adobe Acrobat X (10.1.1)
    cpe:2.3:a:adobe:acrobat:10.1.1
  • Adobe Acrobat X (10.1.3)
    cpe:2.3:a:adobe:acrobat:10.1.3
  • Adobe Acrobat 10.0.1 Professional
    cpe:2.3:a:adobe:acrobat:10.0.1:-:pro
  • Adobe Acrobat X (10.0.3)
    cpe:2.3:a:adobe:acrobat:10.0.3
  • Adobe Acrobat 10.1.5
    cpe:2.3:a:adobe:acrobat:10.1.5
  • Adobe Acrobat X (10.0.2)
    cpe:2.3:a:adobe:acrobat:10.0.2
  • Adobe Acrobat X (10.1)
    cpe:2.3:a:adobe:acrobat:10.1
  • Adobe Acrobat 11.0
    cpe:2.3:a:adobe:acrobat:11.0
  • Adobe Acrobat XI (11.0.1)
    cpe:2.3:a:adobe:acrobat:11.0.1
CVSS
Base: 9.3 (as of 14-02-2013 - 12:51)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
nessus via4
  • NASL family SuSE Local Security Checks
    NASL id SUSE_ACROREAD-8474.NASL
    description Acrobat Reader was updated to 9.5.4 which fixes two critical security issues where attackers supplying PDFs could have caused code execution with acrobat. (CVE-2013-0640 / CVE-2013-0641) More information can be found on : https://www.adobe.com/support/security/bulletins/apsb13-07.html
    last seen 2018-09-01
    modified 2013-11-18
    plugin id 64907
    published 2013-02-27
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=64907
    title SuSE 10 Security Update : acroread (ZYPP Patch Number 8474)
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_ADOBE_READER_APSB13-07.NASL
    description The version of Adobe Reader installed on the remote Mac OS X host is prior to 11.0.2, 10.1.6, or 9.5.4. It is, therefore, affected by the following vulnerabilities : - An unspecified memory corruption issue exists that allows a remote attacker to cause a denial of service or execute arbitrary code via a crafted PDF document. (CVE-2013-0640) - An unspecified buffer overflow condition exists that allows a remote attacker to execute arbitrary code via a crafted PDF document. (CVE-2013-0641) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2018-09-01
    modified 2018-07-14
    plugin id 64787
    published 2013-02-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=64787
    title Adobe Reader < 11.0.2 / 10.1.6 / 9.5.4 Multiple Vulnerabilities (APSA13-02, APSB13-07) (Mac OS X)
  • NASL family Windows
    NASL id ADOBE_ACROBAT_APSA13-02.NASL
    description The version of Adobe Acrobat installed on the remote host is equal or prior to 11.0.1 / 10.1.5 / 9.5.3, or is 11.0.1 and missing a workaround fix. Therefore, it is affected by two unspecified remote code execution vulnerabilities.
    last seen 2018-06-29
    modified 2018-06-27
    plugin id 64644
    published 2013-02-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=64644
    title Adobe Acrobat <= 11.0.1 / 10.1.5 / 9.5.3 Multiple Vulnerabilities (APSA13-02)
  • NASL family Windows
    NASL id ADOBE_ACROBAT_APSB13-07.NASL
    description The version of Adobe Acrobat installed on the remote host is earlier than 11.0.2 / 10.1.6 / 9.5.4. It is, therefore, affected by multiple vulnerabilities : - An unspecified memory corruption error exists that could lead to code execution. (CVE-2013-0640) - An unspecified buffer overflow error exists that could lead to code execution. (CVE-2013-0641)
    last seen 2018-09-02
    modified 2018-06-27
    plugin id 64785
    published 2013-02-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=64785
    title Adobe Acrobat < 11.0.2 / 10.1.6 / 9.5.4 Multiple Vulnerabilities (APSB13-07)
  • NASL family Windows
    NASL id ADOBE_READER_APSA13-02.NASL
    description The version of Adobe Reader installed on the remote host is equal or prior to 11.0.1 / 10.1.5 / 9.5.3, or is 11.0.1 and missing a workaround fix. Therefore, it is affected by two unspecified remote code execution vulnerabilities.
    last seen 2018-06-29
    modified 2018-06-27
    plugin id 64645
    published 2013-02-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=64645
    title Adobe Reader <= 11.0.1 / 10.1.5 / 9.5.3 Multiple Vulnerabilities (APSA13-02)
  • NASL family Windows
    NASL id ADOBE_READER_APSB13-07.NASL
    description The version of Adobe Reader installed on the remote host is earlier than 11.0.2 / 10.1.6 / 9.5.4. It is, therefore, affected by multiple vulnerabilities : - An unspecified memory corruption error exists that could lead to code execution. (CVE-2013-0640) - An unspecified buffer overflow error exists that could lead to code execution. (CVE-2013-0641)
    last seen 2018-09-01
    modified 2018-06-27
    plugin id 64786
    published 2013-02-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=64786
    title Adobe Reader < 11.0.2 / 10.1.6 / 9.5.4 Multiple Vulnerabilities (APSB13-07)
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-201308-03.NASL
    description The remote host is affected by the vulnerability described in GLSA-201308-03 (Adobe Reader: Multiple vulnerabilities) Multiple vulnerabilities have been discovered in Adobe Reader. Please review the CVE identifiers referenced below for details. Impact : A remote attacker could entice a user to open a specially crafted PDF file, possibly resulting in arbitrary code execution or a Denial of Service condition. A local attacker could gain privileges via unspecified vectors. Workaround : There is no known workaround at this time.
    last seen 2018-09-01
    modified 2018-07-11
    plugin id 69454
    published 2013-08-23
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=69454
    title GLSA-201308-03 : Adobe Reader: Multiple vulnerabilities
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2013-0551.NASL
    description Updated acroread packages that fix two security issues are now available for Red Hat Enterprise Linux 5 and 6 Supplementary. The Red Hat Security Response Team has rated this update as having critical security impact. Common Vulnerability Scoring System (CVSS) base scores, which give detailed severity ratings, are available for each vulnerability from the CVE links in the References section. Adobe Reader allows users to view and print documents in Portable Document Format (PDF). This update fixes two security flaws in Adobe Reader. These flaws are detailed in the Adobe Security bulletin APSB13-07, listed in the References section. A specially crafted PDF file could cause Adobe Reader to crash or, potentially, execute arbitrary code as the user running Adobe Reader when opened. (CVE-2013-0640, CVE-2013-0641) All Adobe Reader users should install these updated packages. They contain Adobe Reader version 9.5.4, which is not vulnerable to these issues. All running instances of Adobe Reader must be restarted for the update to take effect.
    last seen 2018-09-12
    modified 2018-09-10
    plugin id 64794
    published 2013-02-22
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=64794
    title RHEL 5 / 6 : acroread (RHSA-2013:0551)
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2013-151.NASL
    description acroread was updated to 9.5.4 to fix remote code execution problems. (CVE-2013-0640, CVE-2013-0641) More information can be found on: http://www.adobe.com/support/security/bulletins/apsb13-07.html
    last seen 2018-09-01
    modified 2018-08-13
    plugin id 74899
    published 2014-06-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=74899
    title openSUSE Security Update : acroread (openSUSE-SU-2013:0335-2)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_11_ACROREAD-130222.NASL
    description Acrobat Reader has been updated to 9.5.4 which fixes two critical security issues where attackers supplying PDFs could have caused code execution with acrobat. (CVE-2013-0640 / CVE-2013-0641) More information can be found on : https://www.adobe.com/support/security/bulletins/apsb13-07.html
    last seen 2018-09-01
    modified 2013-11-18
    plugin id 64905
    published 2013-02-27
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=64905
    title SuSE 11.2 Security Update : acroread (SAT Patch Number 7397)
oval via4
accepted 2013-04-29T04:16:45.808-04:00
class vulnerability
contributors
  • name Shane Shaffer
    organization G2, Inc.
  • name Shane Shaffer
    organization G2, Inc.
  • name Jonathan Baker
    organization The MITRE Corporation
definition_extensions
  • comment Adobe Reader 9 Series is installed
    oval oval:org.mitre.oval:def:6523
  • comment Adobe Reader 10.x is installed
    oval oval:org.mitre.oval:def:12283
  • comment Adobe Reader 11.x is installed
    oval oval:org.mitre.oval:def:16400
  • comment Adobe Acrobat 9 Series is installed
    oval oval:org.mitre.oval:def:6013
  • comment Adobe Acrobat 10.x is installed
    oval oval:org.mitre.oval:def:11989
  • comment Adobe Acrobat 11.x is installed
    oval oval:org.mitre.oval:def:16409
description Buffer overflow in Adobe Reader and Acrobat 9.x before 9.5.4, 10.x before 10.1.6, and 11.x before 11.0.02 allows remote attackers to execute arbitrary code via a crafted PDF document, as exploited in the wild in February 2013.
family windows
id oval:org.mitre.oval:def:16296
status accepted
submitted 2013-02-19T11:01:24.897-05:00
title Unspecified vulnerability in Adobe Reader and Acrobat 9.x through 9.5.3, 10.x through 10.1.5, and 11.x through 11.0.1 allows remote attackers to execute arbitrary code via a crafted PDF document, as exploited in the wild in February 2013, a different vulnerability than CVE-2013-0641
version 9
redhat via4
advisories
bugzilla
id 911099
title CVE-2013-0640 CVE-2013-0641 acroread: Multiple unspecified vulnerabilities allow remote attackers to execute arbitrary code (APSB13-07)
oval
AND
  • OR
    • comment Red Hat Enterprise Linux 6 Client is installed
      oval oval:com.redhat.rhsa:tst:20100842001
    • comment Red Hat Enterprise Linux 6 Server is installed
      oval oval:com.redhat.rhsa:tst:20100842002
    • comment Red Hat Enterprise Linux 6 Workstation is installed
      oval oval:com.redhat.rhsa:tst:20100842003
    • comment Red Hat Enterprise Linux 6 ComputeNode is installed
      oval oval:com.redhat.rhsa:tst:20100842004
  • OR
    • AND
      • comment acroread is earlier than 0:9.5.4-1.el6
        oval oval:com.redhat.rhsa:tst:20130551005
      • comment acroread is signed with Red Hat redhatrelease2 key
        oval oval:com.redhat.rhsa:tst:20100934011
    • AND
      • comment acroread-plugin is earlier than 0:9.5.4-1.el6
        oval oval:com.redhat.rhsa:tst:20130551007
      • comment acroread-plugin is signed with Red Hat redhatrelease2 key
        oval oval:com.redhat.rhsa:tst:20100934013
rhsa
id RHSA-2013:0551
released 2013-02-21
severity Critical
title RHSA-2013:0551: acroread security update (Critical)
rpms
  • acroread-0:9.5.4-1.el6
  • acroread-plugin-0:9.5.4-1.el6
refmap via4
cert-vn VU#422807
confirm
gentoo GLSA-201308-03
misc
suse
  • SUSE-SU-2013:0349
  • openSUSE-SU-2013:0335
  • openSUSE-SU-2013:0342
the hacker news via4
id THN:9D18A086B8C1E6B01851C09B70F5A04C
last seen 2017-01-08
modified 2013-02-20
published 2013-02-20
reporter Mohit Kumar
source http://thehackernews.com/2013/02/patch-released-for-critical-adobe.html
title Patch released for critical Adobe vulnerabilities
Last major update 06-02-2014 - 23:45
Published 13-02-2013 - 20:55
Last modified 18-09-2017 - 21:35
Back to Top