ID CVE-2010-3635
Summary Adobe Flash Media Server (FMS) 3.0.x before 3.0.7, 3.5.x before 3.5.5, and 4.0.x before 4.0.1 allows attackers to execute arbitrary code via unspecified vectors, related to a "segmentation fault vulnerability."
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:flash_media_server:3.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.0.5:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.0.5:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.0.6:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.0.6:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.5:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.5:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.5.2:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.5.2:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.5.3:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.5.3:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:3.5.4:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:3.5.4:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_media_server:4.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_media_server:4.0:*:*:*:*:*:*:*
CVSS
Base: 10.0 (as of 19-09-2017 - 01:31)
Impact:
Exploitability:
CWE CWE-94
CAPEC
  • Code Injection
    An adversary exploits a weakness in input validation on the target to inject new code into that which is currently executing. This differs from code inclusion in that code inclusion involves the addition or replacement of a reference to a code file, which is subsequently loaded by the target and used as part of the code of some application.
  • Leverage Executable Code in Non-Executable Files
    An attack of this type exploits a system's trust in configuration and resource files. When the executable loads the resource (such as an image file or configuration file) the attacker has modified the file to either execute malicious code directly or manipulate the target process (e.g. application server) to execute based on the malicious configuration parameters. Since systems are increasingly interrelated mashing up resources from local and remote sources the possibility of this attack occurring is high.
  • Manipulating User-Controlled Variables
    This attack targets user controlled variables (DEBUG=1, PHP Globals, and So Forth). An attacker can override environment variables leveraging user-supplied, untrusted query variables directly used on the application server without any data sanitization. In extreme cases, the attacker can change variables controlling the business logic of the application. For instance, in languages like PHP, a number of poorly set default configurations may allow the user to override variables.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
cvss-vector via4 AV:N/AC:L/Au:N/C:C/I:C/A:C
oval via4
accepted 2011-01-10T04:00:03.791-05:00
class vulnerability
contributors
name SecPod Team
organization SecPod Technologies
definition_extensions
comment Adobe Flash Media Server is installed
oval oval:org.mitre.oval:def:11587
description Adobe Flash Media Server (FMS) 3.0.x before 3.0.7, 3.5.x before 3.5.5, and 4.0.x before 4.0.1 allows attackers to execute arbitrary code via unspecified vectors, related to a "segmentation fault vulnerability."
family windows
id oval:org.mitre.oval:def:11333
status accepted
submitted 2010-11-30T07:28:32
title Segmentation fault vulnerability in Adobe Flash Media Server (FMS) version 3.0.x less than 3.0.7, 3.5.x less than 3.5.5, and 4.0.x less than 4.0.1
version 6
refmap via4
bid 44753
confirm http://www.adobe.com/support/security/bulletins/apsb10-27.html
Last major update 19-09-2017 - 01:31
Published 10-11-2010 - 03:00
Back to Top