ID CVE-2009-3229
Summary The core server component in PostgreSQL 8.4 before 8.4.1, 8.3 before 8.3.8, and 8.2 before 8.2.14 allows remote authenticated users to cause a denial of service (backend shutdown) by "re-LOAD-ing" libraries from a certain plugins directory.
References
Vulnerable Configurations
  • cpe:2.3:a:postgresql:postgresql:8.2:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.2:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.3:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.4:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.4:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.5:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.6:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.6:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.7:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.7:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.8:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.8:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.9:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.9:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.10:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.10:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.11:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.11:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.12:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.12:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.2.13:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.2.13:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.3:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.3:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.3.1:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.3.1:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.3.2:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.3.2:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.3.3:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.3.3:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.3.4:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.3.4:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.3.5:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.3.5:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.3.6:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.3.6:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.3.7:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.3.7:*:*:*:*:*:*:*
  • cpe:2.3:a:postgresql:postgresql:8.4:*:*:*:*:*:*:*
    cpe:2.3:a:postgresql:postgresql:8.4:*:*:*:*:*:*:*
CVSS
Base: 4.0 (as of 10-10-2018 - 19:43)
Impact:
Exploitability:
CWE NVD-CWE-noinfo
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW SINGLE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:L/Au:S/C:N/I:N/A:P
refmap via4
bid 36314
bugtraq 20100307 rPSA-2010-0012-1 postgresql postgresql-contrib postgresql-server
confirm
debian DSA-1900
fedora
  • FEDORA-2009-9473
  • FEDORA-2009-9474
hp
  • HPSBMU02781
  • SSRT100617
secunia
  • 36660
  • 36727
  • 36800
  • 36837
sunalert 270408
suse
  • SUSE-SR:2009:016
  • SUSE-SR:2009:017
ubuntu USN-834-1
statements via4
contributor Tomas Hoger
lastmodified 2009-09-24
organization Red Hat
statement Not vulnerable. This issue did not affect the versions of PostgreSQL as shipped with Red Hat Enterprise Linux 3, 4, or 5. In PostgreSQL versions prior to 8.2, only database administrator was able to LOAD additional plugins and use it to cause server crash. However, this does not bypass trust boundary, so its not a security flaw for older PostgreSQL versions. Additionally, no plugins are shipped in Red Hat PostgreSQL packages by default. This issue was addressed in Red Hat Application Stack v2 via https://rhn.redhat.com/errata/RHSA-2009-1461.html .
Last major update 10-10-2018 - 19:43
Published 17-09-2009 - 10:30
Back to Top