ID CVE-2008-2841
Summary Argument injection vulnerability in XChat 2.8.7b and earlier on Windows, when Internet Explorer is used, allows remote attackers to execute arbitrary commands via the --command parameter in an ircs:// URI.
References
Vulnerable Configurations
  • cpe:2.3:o:microsoft:windows_nt:*:*:*:*:*:*:*:*
    cpe:2.3:o:microsoft:windows_nt:*:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:*:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:*:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.3.9:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.3.9:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.3.10:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.3.10:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.3.11:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.3.11:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.3.12:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.3.12:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.3.13:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.3.13:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.4:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.4:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.4.1:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.4.2:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.4.2:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.4.3:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.4.3:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.5.6:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.5.6:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.0:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.0:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.1:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.1:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.2:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.2:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.3:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.3:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.4:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.4:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.5:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.5:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.6:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.6:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.7:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.7:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.8:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.8:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.8.9:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.8.9:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.0:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.0:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.1:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.1:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.2:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.2:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.3:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.3:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.4:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.4:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.5:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.5:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.6:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.6:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.7:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.7:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.8:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.8:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:1.9.9:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:1.9.9:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.0.5:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.0.5:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.0.6:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.0.6:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.0.7:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.0.7:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.0.8:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.0.8:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.6.7:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.6.7:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.0:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.0:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.1:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.1:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.3:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.3:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.3:c:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.3:c:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.3:e:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.3:e:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.4:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.4:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.5:b:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.5:b:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.5:e:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.5:e:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.6:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.6:*:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.7:a:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.7:a:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.7:b:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.7:b:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.7:c:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.7:c:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.7:d:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.7:d:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.7:e:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.7:e:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.7:f:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.7:f:*:*:*:*:*:*
  • cpe:2.3:a:xchat:xchat:2.8.7b:*:*:*:*:*:*:*
    cpe:2.3:a:xchat:xchat:2.8.7b:*:*:*:*:*:*:*
CVSS
Base: 6.8 (as of 29-09-2017 - 01:31)
Impact:
Exploitability:
CWE CWE-94
CAPEC
  • Code Injection
    An adversary exploits a weakness in input validation on the target to inject new code into that which is currently executing. This differs from code inclusion in that code inclusion involves the addition or replacement of a reference to a code file, which is subsequently loaded by the target and used as part of the code of some application.
  • Leverage Executable Code in Non-Executable Files
    An attack of this type exploits a system's trust in configuration and resource files. When the executable loads the resource (such as an image file or configuration file) the attacker has modified the file to either execute malicious code directly or manipulate the target process (e.g. application server) to execute based on the malicious configuration parameters. Since systems are increasingly interrelated mashing up resources from local and remote sources the possibility of this attack occurring is high.
  • Manipulating User-Controlled Variables
    This attack targets user controlled variables (DEBUG=1, PHP Globals, and So Forth). An attacker can override environment variables leveraging user-supplied, untrusted query variables directly used on the application server without any data sanitization. In extreme cases, the attacker can change variables controlling the business logic of the application. For instance, in languages like PHP, a number of poorly set default configurations may allow the user to override variables.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:P/I:P/A:P
refmap via4
bid 29696
confirm http://forum.xchat.org/viewtopic.php?t=4218
exploit-db 5795
secunia 30695
xf xchat-ircs-command-execution(43065)
statements via4
contributor Mark J Cox
lastmodified 2008-07-07
organization Red Hat
statement Not vulnerable. This issue did not affect the versions of XChat as shipped with Red Hat Enterprise Linux.
Last major update 29-09-2017 - 01:31
Published 24-06-2008 - 19:41
Last modified 29-09-2017 - 01:31
Back to Top