ID CVE-2007-3892
Summary Microsoft Internet Explorer 5.01 through 7 allows remote attackers to spoof the URL address bar and other "trust UI" components via unspecified vectors, a different issue than CVE-2007-1091 and CVE-2007-3826. Secunia advisory: http://secunia.com/advisories/23469/ Contains patch information.
References
Vulnerable Configurations
  • cpe:2.3:a:microsoft:ie:5.00.2516.1900:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.2516.1900:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.2614.3500:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.2614.3500:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.2919.800:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.2919.800:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.2919.3800:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.2919.3800:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.2919.6307:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.2919.6307:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.2920.0000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.2920.0000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.3103.1000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.3103.1000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.3105.0106:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.3105.0106:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.3314.2101:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.3314.2101:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.3315.1000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.3315.1000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.3502.1000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.3502.1000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:5.00.3700.1000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:5.00.3700.1000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.2462.0000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.2462.0000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.2479.0006:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.2479.0006:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.2600.0000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.2600.0000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.2800.1106:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.2800.1106:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.2900.2180:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.2900.2180:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.3663.0000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.3663.0000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.3718.0000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.3718.0000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.3790.0000:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.3790.0000:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.3790.1830:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.3790.1830:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:6.00.3790.3959:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:6.00.3790.3959:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:7.0:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:7.0:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:7.0:beta1:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:7.0:beta1:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:7.0:beta2:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:7.0:beta2:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:7.0:beta3:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:7.0:beta3:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:7.00.5730.1100:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:7.00.5730.1100:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:7.00.6000.16386:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:7.00.6000.16386:*:*:*:*:*:*:*
  • cpe:2.3:a:microsoft:ie:7.00.6000.16441:*:*:*:*:*:*:*
    cpe:2.3:a:microsoft:ie:7.00.6000.16441:*:*:*:*:*:*:*
CVSS
Base: 7.5 (as of 15-10-2018 - 21:31)
Impact:
Exploitability:
CWE CWE-94
CAPEC
  • Code Injection
    An adversary exploits a weakness in input validation on the target to inject new code into that which is currently executing. This differs from code inclusion in that code inclusion involves the addition or replacement of a reference to a code file, which is subsequently loaded by the target and used as part of the code of some application.
  • Leverage Executable Code in Non-Executable Files
    An attack of this type exploits a system's trust in configuration and resource files. When the executable loads the resource (such as an image file or configuration file) the attacker has modified the file to either execute malicious code directly or manipulate the target process (e.g. application server) to execute based on the malicious configuration parameters. Since systems are increasingly interrelated mashing up resources from local and remote sources the possibility of this attack occurring is high.
  • Manipulating User-Controlled Variables
    This attack targets user controlled variables (DEBUG=1, PHP Globals, and So Forth). An attacker can override environment variables leveraging user-supplied, untrusted query variables directly used on the application server without any data sanitization. In extreme cases, the attacker can change variables controlling the business logic of the application. For instance, in languages like PHP, a number of poorly set default configurations may allow the user to override variables.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:P/I:P/A:P
oval via4
accepted 2014-02-24T04:03:11.628-05:00
class vulnerability
contributors
  • name Robert L. Hollis
    organization ThreatGuard, Inc.
  • name Jeff Cheng
    organization Opsware, Inc.
  • name Jeff Cheng
    organization Opsware, Inc.
  • name Jeff Cheng
    organization Opsware, Inc.
  • name Jeff Cheng
    organization Opsware, Inc.
  • name Jeff Cheng
    organization Opsware, Inc.
  • name Jeff Cheng
    organization Opsware, Inc.
  • name Chandan S
    organization SecPod Technologies
  • name Maria Mikhno
    organization ALTX-SOFT
definition_extensions
  • comment Microsoft Windows 2000 SP4 or later is installed
    oval oval:org.mitre.oval:def:229
  • comment Microsoft Internet Explorer 5.01 SP4 is installed
    oval oval:org.mitre.oval:def:325
  • comment Microsoft Windows 2000 SP4 or later is installed
    oval oval:org.mitre.oval:def:229
  • comment Microsoft Windows XP SP2 or later is installed
    oval oval:org.mitre.oval:def:521
  • comment Microsoft Internet Explorer 6 is installed
    oval oval:org.mitre.oval:def:563
  • comment Microsoft Windows Server 2003 SP1 (x86) is installed
    oval oval:org.mitre.oval:def:565
  • comment Microsoft Windows Server 2003 (x64) is installed
    oval oval:org.mitre.oval:def:730
  • comment Microsoft Windows Server 2003 SP1 for Itanium is installed
    oval oval:org.mitre.oval:def:1205
  • comment Microsoft Internet Explorer 6 is installed
    oval oval:org.mitre.oval:def:563
  • comment Microsoft Windows Server 2003 SP2 (x86) is installed
    oval oval:org.mitre.oval:def:1935
  • comment Microsoft Windows Server 2003 SP2 (x64) is installed
    oval oval:org.mitre.oval:def:2161
  • comment Microsoft Windows Server 2003 (ia64) SP2 is installed
    oval oval:org.mitre.oval:def:1442
  • comment Microsoft Internet Explorer 6 is installed
    oval oval:org.mitre.oval:def:563
  • comment Microsoft Windows XP SP1 (64-bit) is installed
    oval oval:org.mitre.oval:def:480
  • comment Microsoft Internet Explorer 6 is installed
    oval oval:org.mitre.oval:def:563
  • comment Microsoft Internet Explorer 6 is installed
    oval oval:org.mitre.oval:def:563
  • comment Microsoft Windows XP x64 Edition SP2 is installed
    oval oval:org.mitre.oval:def:4193
  • comment Microsoft Windows XP SP2 or later is installed
    oval oval:org.mitre.oval:def:521
  • comment Microsoft Windows XP SP1 (64-bit) is installed
    oval oval:org.mitre.oval:def:480
  • comment Microsoft Windows Server 2003 SP1 (x86) is installed
    oval oval:org.mitre.oval:def:565
  • comment Microsoft Windows Server 2003 SP2 (x86) is installed
    oval oval:org.mitre.oval:def:1935
  • comment Microsoft Windows XP x64 Edition SP2 is installed
    oval oval:org.mitre.oval:def:4193
  • comment Microsoft Internet Explorer 7 is installed
    oval oval:org.mitre.oval:def:627
  • comment Microsoft Windows Vista is installed
    oval oval:org.mitre.oval:def:228
  • comment Microsoft Internet Explorer 7 is installed
    oval oval:org.mitre.oval:def:627
description Microsoft Internet Explorer 5.01 through 7 allows remote attackers to spoof the URL address bar and other "trust UI" components via unspecified vectors, a different issue than CVE-2007-1091 and CVE-2007-3826.
family windows
id oval:org.mitre.oval:def:2244
status accepted
submitted 2007-10-10T04:39:42
title Address Bar Spoofing Vulnerability
version 70
refmap via4
bid 25915
cert TA07-282A
hp
  • HPSBST02280
  • SSRT071480
ms MS07-057
sectrack 1018788
secunia 27133
vupen ADV-2007-3437
Last major update 15-10-2018 - 21:31
Published 09-10-2007 - 22:17
Back to Top