ID CVE-2006-7204
Summary The imap_body function in PHP before 4.4.4 does not implement safemode or open_basedir checks, which allows local users to read arbitrary files or list arbitrary directory contents. The vendor has addressed this issue with the following product update: http://www.php.net/downloads.php
References
Vulnerable Configurations
  • cpe:2.3:a:php:php:4.4.0:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:4.4.0:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:4.4.1:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:4.4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:4.4.2:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:4.4.2:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:4.4.3:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:4.4.3:*:*:*:*:*:*:*
CVSS
Base: 2.1 (as of 05-09-2008 - 21:16)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
LOCAL LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
cvss-vector via4 AV:L/AC:L/Au:N/C:P/I:N/A:N
refmap via4
confirm http://us2.php.net/ChangeLog-4.php#4.4.4
misc http://bugs.php.net/bug.php?id=37265
osvdb 28005
secunia 21546
statements via4
  • contributor Vincent Danen
    lastmodified 2007-09-21
    organization Mandriva
    statement Due to the nature of safe_mode and open_basedir restrictions, and in alignment with the PHP group’s stance on these features, Mandriva does not consider this a security issue.
  • contributor Mark J Cox
    lastmodified 2007-05-29
    organization Red Hat
    statement We do not consider these to be security issues. For more details see http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169857#c1 and http://www.php.net/security-note.php
Last major update 05-09-2008 - 21:16
Published 22-05-2007 - 19:30
Last modified 05-09-2008 - 21:16
Back to Top