ID CVE-2006-5868
Summary Multiple buffer overflows in Imagemagick 6.0 before 6.0.6.2, and 6.2 before 6.2.4.5, has unknown impact and user-assisted attack vectors via a crafted SGI image.
References
Vulnerable Configurations
  • cpe:2.3:a:imagemagick:imagemagick:6.0:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.0.7:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.0.7:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.1.4:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.1.4:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.2.5:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.2.7:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.2.7:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.3.5:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.3.5:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.4.4:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.4.4:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.5:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.5:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.5.3:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.5.3:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.6:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.6:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.0.6.1:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.0.6.1:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.0.7:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.0.7:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.0.8:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.0.8:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.1.7:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.1.7:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.2:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.2.5:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.3:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.3.4:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.3.4:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.3.6:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.3.6:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.4:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.4:*:*:*:*:*:*:*
  • cpe:2.3:a:imagemagick:imagemagick:6.2.4.3:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:6.2.4.3:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:3.1:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:3.1:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:4.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:4.0:*:*:*:*:*:*:*
  • cpe:2.3:o:canonical:ubuntu_linux:5.10:*:*:*:*:*:*:*
    cpe:2.3:o:canonical:ubuntu_linux:5.10:*:*:*:*:*:*:*
  • cpe:2.3:o:canonical:ubuntu_linux:6.06:*:*:*:lts:*:*:*
    cpe:2.3:o:canonical:ubuntu_linux:6.06:*:*:*:lts:*:*:*
CVSS
Base: 9.3 (as of 17-10-2018 - 17:51)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
cvss-vector via4 AV:N/AC:M/Au:N/C:C/I:C/A:C
oval via4
accepted 2013-04-29T04:07:05.758-04:00
class vulnerability
contributors
  • name Aharon Chernin
    organization SCAP.com, LLC
  • name Dragos Prisaca
    organization G2, Inc.
definition_extensions
  • comment The operating system installed on the system is Red Hat Enterprise Linux 3
    oval oval:org.mitre.oval:def:11782
  • comment CentOS Linux 3.x
    oval oval:org.mitre.oval:def:16651
  • comment The operating system installed on the system is Red Hat Enterprise Linux 4
    oval oval:org.mitre.oval:def:11831
  • comment CentOS Linux 4.x
    oval oval:org.mitre.oval:def:16636
  • comment Oracle Linux 4.x
    oval oval:org.mitre.oval:def:15990
description Multiple buffer overflows in Imagemagick 6.0 before 6.0.6.2, and 6.2 before 6.2.4.5, has unknown impact and user-assisted attack vectors via a crafted SGI image.
family unix
id oval:org.mitre.oval:def:10612
status accepted
submitted 2010-07-09T03:56:16-04:00
title Multiple buffer overflows in Imagemagick 6.0 before 6.0.6.2, and 6.2 before 6.2.4.5, has unknown impact and user-assisted attack vectors via a crafted SGI image.
version 23
redhat via4
advisories
bugzilla
id 217558
title CVE-2006-5868 Insufficient boundary check in ImageMagick's SGIDecode()
oval
OR
  • AND
    • comment Red Hat Enterprise Linux 3 is installed
      oval oval:com.redhat.rhba:tst:20070026001
    • OR
      • AND
        • comment ImageMagick is earlier than 0:5.5.6-24
          oval oval:com.redhat.rhsa:tst:20070015002
        • comment ImageMagick is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015003
      • AND
        • comment ImageMagick-c++ is earlier than 0:5.5.6-24
          oval oval:com.redhat.rhsa:tst:20070015010
        • comment ImageMagick-c++ is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015011
      • AND
        • comment ImageMagick-c++-devel is earlier than 0:5.5.6-24
          oval oval:com.redhat.rhsa:tst:20070015008
        • comment ImageMagick-c++-devel is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015009
      • AND
        • comment ImageMagick-devel is earlier than 0:5.5.6-24
          oval oval:com.redhat.rhsa:tst:20070015004
        • comment ImageMagick-devel is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015005
      • AND
        • comment ImageMagick-perl is earlier than 0:5.5.6-24
          oval oval:com.redhat.rhsa:tst:20070015006
        • comment ImageMagick-perl is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015007
  • AND
    • comment Red Hat Enterprise Linux 4 is installed
      oval oval:com.redhat.rhba:tst:20070304001
    • OR
      • AND
        • comment ImageMagick is earlier than 0:6.0.7.1-16.0.3
          oval oval:com.redhat.rhsa:tst:20070015013
        • comment ImageMagick is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015003
      • AND
        • comment ImageMagick-c++ is earlier than 0:6.0.7.1-16.0.3
          oval oval:com.redhat.rhsa:tst:20070015014
        • comment ImageMagick-c++ is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015011
      • AND
        • comment ImageMagick-c++-devel is earlier than 0:6.0.7.1-16.0.3
          oval oval:com.redhat.rhsa:tst:20070015016
        • comment ImageMagick-c++-devel is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015009
      • AND
        • comment ImageMagick-devel is earlier than 0:6.0.7.1-16.0.3
          oval oval:com.redhat.rhsa:tst:20070015015
        • comment ImageMagick-devel is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015005
      • AND
        • comment ImageMagick-perl is earlier than 0:6.0.7.1-16.0.3
          oval oval:com.redhat.rhsa:tst:20070015017
        • comment ImageMagick-perl is signed with Red Hat master key
          oval oval:com.redhat.rhsa:tst:20070015007
rhsa
id RHSA-2007:0015
released 2007-02-15
severity Moderate
title RHSA-2007:0015: ImageMagick security update (Moderate)
rpms
  • ImageMagick-0:5.5.6-24
  • ImageMagick-c++-0:5.5.6-24
  • ImageMagick-c++-devel-0:5.5.6-24
  • ImageMagick-devel-0:5.5.6-24
  • ImageMagick-perl-0:5.5.6-24
  • ImageMagick-0:6.0.7.1-16.0.3
  • ImageMagick-c++-0:6.0.7.1-16.0.3
  • ImageMagick-c++-devel-0:6.0.7.1-16.0.3
  • ImageMagick-devel-0:6.0.7.1-16.0.3
  • ImageMagick-perl-0:6.0.7.1-16.0.3
refmap via4
bid 21185
debian DSA-1213
mandriva MDKSA-2006:223
secunia
  • 22998
  • 23101
  • 23219
  • 24186
  • 24284
sgi 20070201-01-P
ubuntu USN-386-1
statements via4
contributor Mark J Cox
lastmodified 2007-03-14
organization Red Hat
statement Red Hat Enterprise Linux 5 is not vulnerable to this issue as it contains a backported patch.
Last major update 17-10-2018 - 17:51
Published 22-11-2006 - 01:07
Back to Top