ID CVE-2006-4486
Summary Integer overflow in memory allocation routines in PHP before 5.1.6, when running on a 64-bit system, allows context-dependent attackers to bypass the memory_limit restriction.
References
Vulnerable Configurations
  • cpe:2.3:a:php:php:5.1.0:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.1.2:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.1.4:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.1.4:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.1.5:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.1.5:*:*:*:*:*:*:*
CVSS
Base: 2.6 (as of 30-10-2018 - 16:25)
Impact:
Exploitability:
CWE CWE-189
CAPEC
Access
VectorComplexityAuthentication
NETWORK HIGH NONE
Impact
ConfidentialityIntegrityAvailability
NONE PARTIAL NONE
cvss-vector via4 AV:N/AC:H/Au:N/C:N/I:P/A:N
oval via4
accepted 2013-04-29T04:11:23.846-04:00
class vulnerability
contributors
  • name Aharon Chernin
    organization SCAP.com, LLC
  • name Dragos Prisaca
    organization G2, Inc.
definition_extensions
  • comment The operating system installed on the system is Red Hat Enterprise Linux 3
    oval oval:org.mitre.oval:def:11782
  • comment CentOS Linux 3.x
    oval oval:org.mitre.oval:def:16651
  • comment The operating system installed on the system is Red Hat Enterprise Linux 4
    oval oval:org.mitre.oval:def:11831
  • comment CentOS Linux 4.x
    oval oval:org.mitre.oval:def:16636
  • comment Oracle Linux 4.x
    oval oval:org.mitre.oval:def:15990
description Integer overflow in memory allocation routines in PHP before 5.1.6, when running on a 64-bit system, allows context-dependent attackers to bypass the memory_limit restriction.
family unix
id oval:org.mitre.oval:def:11086
status accepted
submitted 2010-07-09T03:56:16-04:00
title Integer overflow in memory allocation routines in PHP before 5.1.6, when running on a 64-bit system, allows context-dependent attackers to bypass the memory_limit restriction.
version 23
redhat via4
advisories
  • bugzilla
    id 206959
    title CVE-2006-3016 PHP session ID validation
    oval
    OR
    • AND
      comment Red Hat Enterprise Linux 3 is installed
      oval oval:com.redhat.rhba:tst:20070026001
    • AND
      comment Red Hat Enterprise Linux 4 is installed
      oval oval:com.redhat.rhba:tst:20070304001
    rhsa
    id RHSA-2006:0669
    released 2006-09-21
    severity Moderate
    title RHSA-2006:0669: php security update (Moderate)
  • rhsa
    id RHSA-2006:0682
  • rhsa
    id RHSA-2006:0688
refmap via4
bid 19582
bugtraq 20061005 rPSA-2006-0182-1 php php-mysql php-pgsql
confirm
debian DSA-1331
misc http://www.hardened-php.net/hphp/changelog.html#hardening_patch_0.4.14
sectrack 1016984
secunia
  • 21546
  • 22004
  • 22069
  • 22225
  • 22331
  • 22440
  • 22487
  • 22538
  • 25945
sgi 20061001-01-P
suse SUSE-SA:2006:052
turbo TLSA-2006-38
ubuntu USN-362-1
Last major update 30-10-2018 - 16:25
Published 31-08-2006 - 21:04
Back to Top