ID CVE-2006-1542
Summary Stack-based buffer overflow in Python 2.4.2 and earlier, running on Linux 2.6.12.5 under gcc 4.0.3 with libc 2.3.5, allows local users to cause a "stack overflow," and possibly gain privileges, by running a script from a current working directory that has a long name, related to the realpath function. NOTE: this might not be a vulnerability. However, the fact that it appears in a programming language interpreter could mean that some applications are affected, although attack scenarios might be limited because the attacker might already need to cross privilege boundaries to cause an exploitable program to be placed in a directory with a long name; or, depending on the method that Python uses to determine the current working directory, setuid applications might be affected. Successful exploitation requires that the Python is running on Linux 2.6.12.5 under gcc 4.0.3 with libc 2.3.5
References
Vulnerable Configurations
  • cpe:2.3:a:python_software_foundation:python:2.2:*:*:*:*:*:*:*
    cpe:2.3:a:python_software_foundation:python:2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:python_software_foundation:python:2.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:python_software_foundation:python:2.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:python_software_foundation:python:2.3:*:*:*:*:*:*:*
    cpe:2.3:a:python_software_foundation:python:2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:python_software_foundation:python:2.3.1:*:*:*:*:*:*:*
    cpe:2.3:a:python_software_foundation:python:2.3.1:*:*:*:*:*:*:*
  • cpe:2.3:a:python_software_foundation:python:2.3.2:*:*:*:*:*:*:*
    cpe:2.3:a:python_software_foundation:python:2.3.2:*:*:*:*:*:*:*
  • cpe:2.3:a:python_software_foundation:python:2.3.3:*:*:*:*:*:*:*
    cpe:2.3:a:python_software_foundation:python:2.3.3:*:*:*:*:*:*:*
  • cpe:2.3:a:python_software_foundation:python:2.3.4:*:*:*:*:*:*:*
    cpe:2.3:a:python_software_foundation:python:2.3.4:*:*:*:*:*:*:*
  • cpe:2.3:a:python_software_foundation:python:2.4:*:*:*:*:*:*:*
    cpe:2.3:a:python_software_foundation:python:2.4:*:*:*:*:*:*:*
  • cpe:2.3:a:python_software_foundation:python:*:*:*:*:*:*:*:*
    cpe:2.3:a:python_software_foundation:python:*:*:*:*:*:*:*:*
CVSS
Base: 3.7 (as of 19-10-2017 - 01:29)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
LOCAL HIGH NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:L/AC:H/Au:N/C:P/I:P/A:P
redhat via4
advisories
rhsa
id RHSA-2008:0629
refmap via4
exploit-db 1591
misc http://www.gotfault.net/research/exploit/gexp-python.py
secunia 31492
statements via4
contributor Mark J Cox
lastmodified 2007-03-14
organization Red Hat
statement Red Hat is aware of this issue and is tracking it via the following bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=187900 The Red Hat Security Response Team has rated this issue as having low security impact, a future update may address this flaw. More information regarding issue severity can be found here: http://www.redhat.com/security/updates/classification/ Red Hat Enterprise Linux 5 is not vulnerable to this issue as it contains a backported patch.
Last major update 19-10-2017 - 01:29
Published 30-03-2006 - 11:02
Back to Top