ID CVE-2004-0788
Summary Integer overflow in the ICO image decoder for (1) gdk-pixbuf before 0.22 and (2) gtk2 before 2.2.4 allows remote attackers to cause a denial of service (application crash) via a crafted ICO file.
References
Vulnerable Configurations
  • cpe:2.3:a:gnome:gdkpixbuf:0.17:*:*:*:*:*:*:*
    cpe:2.3:a:gnome:gdkpixbuf:0.17:*:*:*:*:*:*:*
  • cpe:2.3:a:gnome:gdkpixbuf:0.18:*:*:*:*:*:*:*
    cpe:2.3:a:gnome:gdkpixbuf:0.18:*:*:*:*:*:*:*
  • cpe:2.3:a:gnome:gdkpixbuf:0.20:*:*:*:*:*:*:*
    cpe:2.3:a:gnome:gdkpixbuf:0.20:*:*:*:*:*:*:*
  • cpe:2.3:a:gnome:gdkpixbuf:0.22:*:*:*:*:*:*:*
    cpe:2.3:a:gnome:gdkpixbuf:0.22:*:*:*:*:*:*:*
  • cpe:2.3:a:gtk:gtk\+:2.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:gtk:gtk\+:2.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:gtk:gtk\+:2.0.6:*:*:*:*:*:*:*
    cpe:2.3:a:gtk:gtk\+:2.0.6:*:*:*:*:*:*:*
  • cpe:2.3:a:gtk:gtk\+:2.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:gtk:gtk\+:2.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:gtk:gtk\+:2.2.3:*:*:*:*:*:*:*
    cpe:2.3:a:gtk:gtk\+:2.2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:gtk:gtk\+:2.2.4:*:*:*:*:*:*:*
    cpe:2.3:a:gtk:gtk\+:2.2.4:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 19-10-2018 - 15:30)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:P
oval via4
accepted 2013-04-29T04:06:14.702-04:00
class vulnerability
contributors
  • name Aharon Chernin
    organization SCAP.com, LLC
  • name Dragos Prisaca
    organization G2, Inc.
definition_extensions
  • comment The operating system installed on the system is Red Hat Enterprise Linux 3
    oval oval:org.mitre.oval:def:11782
  • comment CentOS Linux 3.x
    oval oval:org.mitre.oval:def:16651
description Integer overflow in the ICO image decoder for (1) gdk-pixbuf before 0.22 and (2) gtk2 before 2.2.4 allows remote attackers to cause a denial of service (application crash) via a crafted ICO file.
family unix
id oval:org.mitre.oval:def:10506
status accepted
submitted 2010-07-09T03:56:16-04:00
title Integer overflow in the ICO image decoder for (1) gdk-pixbuf before 0.22 and (2) gtk2 before 2.2.4 allows remote attackers to cause a denial of service (application crash) via a crafted ICO file.
version 29
redhat via4
advisories
  • rhsa
    id RHSA-2004:447
  • rhsa
    id RHSA-2004:466
rpms
  • gdk-pixbuf-1:0.22.0-11.3.3
  • gdk-pixbuf-debuginfo-1:0.22.0-11.3.3
  • gdk-pixbuf-devel-1:0.22.0-11.3.3
  • gdk-pixbuf-gnome-1:0.22.0-11.3.3
  • gtk2-0:2.2.4-8.1
  • gtk2-debuginfo-0:2.2.4-8.1
  • gtk2-devel-0:2.2.4-8.1
refmap via4
bid 11195
cert-vn VU#577654
conectiva CLA-2004:875
debian DSA-546
fedora
  • FLSA-2005:155510
  • FLSA:2005
mandrake MDKSA-2004:095
mandriva MDKSA-2005:214
secunia 17657
xf gtk-ico-integer-bo(17387)
Last major update 19-10-2018 - 15:30
Published 20-10-2004 - 04:00
Last modified 19-10-2018 - 15:30
Back to Top