ID CVE-2001-1564
Summary setrlimit in HP-UX 10.01, 10.10, 10.24, 10.20, 11.00, 11.04 and 11.11 does not properly enforce core file size on processes after setuid or setgid privileges are dropped, which could allow local users to cause a denial of service by exhausting available disk space.
References
Vulnerable Configurations
  • cpe:2.3:o:hp:hp-ux:10.01:*:*:*:*:*:*:*
    cpe:2.3:o:hp:hp-ux:10.01:*:*:*:*:*:*:*
  • cpe:2.3:o:hp:hp-ux:10.10:*:*:*:*:*:*:*
    cpe:2.3:o:hp:hp-ux:10.10:*:*:*:*:*:*:*
  • cpe:2.3:o:hp:hp-ux:10.20:*:*:*:*:*:*:*
    cpe:2.3:o:hp:hp-ux:10.20:*:*:*:*:*:*:*
  • cpe:2.3:o:hp:hp-ux:10.24:*:*:*:*:*:*:*
    cpe:2.3:o:hp:hp-ux:10.24:*:*:*:*:*:*:*
  • cpe:2.3:o:hp:hp-ux:11.00:*:*:*:*:*:*:*
    cpe:2.3:o:hp:hp-ux:11.00:*:*:*:*:*:*:*
  • cpe:2.3:o:hp:hp-ux:11.04:*:*:*:*:*:*:*
    cpe:2.3:o:hp:hp-ux:11.04:*:*:*:*:*:*:*
  • cpe:2.3:o:hp:hp-ux:11.11:*:*:*:*:*:*:*
    cpe:2.3:o:hp:hp-ux:11.11:*:*:*:*:*:*:*
CVSS
Base: 2.1 (as of 12-10-2017 - 01:29)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
LOCAL LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:L/AC:L/Au:N/C:N/I:N/A:P
oval via4
accepted 2014-03-24T04:01:39.887-04:00
class vulnerability
contributors
  • name Michael Wood
    organization Hewlett-Packard
  • name Michael Wood
    organization Hewlett-Packard
  • name Sushant Kumar Singh
    organization Hewlett-Packard
description setrlimit in HP-UX 10.01, 10.10, 10.24, 10.20, 11.00, 11.04 and 11.11 does not properly enforce core file size on processes after setuid or setgid privileges are dropeed, which could allow local users to cause a denial of service by exhausting available disk space.
family unix
id oval:org.mitre.oval:def:5159
status accepted
submitted 2008-07-09T16:48:34.000-04:00
title HP-UX Running setrlimit(1M), Denial of Service (DoS)
version 34
refmap via4
bid 3416
hp HPSBUX0107-156
xf hpux-setrlimit-dos(6810)
Last major update 12-10-2017 - 01:29
Published 31-12-2001 - 05:00
Back to Top