Max CVSS 7.5 Min CVSS 5.0 Total Count2
IDCVSSSummaryLast (major) updatePublished
CVE-2020-14400 5.0
** DISPUTED ** An issue was discovered in LibVNCServer before 0.9.13. Byte-aligned data is accessed through uint16_t pointers in libvncserver/translate.c. NOTE: Third parties do not consider this to be a vulnerability as there is no known path of exp
27-02-2023 - 18:14 17-06-2020 - 16:15
CVE-2020-14399 5.0
** DISPUTED ** An issue was discovered in LibVNCServer before 0.9.13. Byte-aligned data is accessed through uint32_t pointers in libvncclient/rfbproto.c. NOTE: there is reportedly "no trust boundary crossed."
27-02-2023 - 18:14 17-06-2020 - 16:15
CVE-2017-18922 7.5
It was discovered that websockets.c in LibVNCServer prior to 0.9.12 did not properly decode certain WebSocket frames. A malicious attacker could exploit this by sending specially crafted WebSocket frames to a server, causing a heap-based buffer overf
01-04-2022 - 18:08 30-06-2020 - 11:15
CVE-2018-21247 5.0
An issue was discovered in LibVNCServer before 0.9.13. There is an information leak (of uninitialized memory contents) in the libvncclient/rfbproto.c ConnectToRFBRepeater function.
10-03-2022 - 15:29 17-06-2020 - 16:15
CVE-2019-20839 5.0
libvncclient/sockets.c in LibVNCServer before 0.9.13 has a buffer overflow via a long socket filename.
10-03-2022 - 15:23 17-06-2020 - 16:15
CVE-2019-20840 5.0
An issue was discovered in LibVNCServer before 0.9.13. libvncserver/ws_decode.c can lead to a crash because of unaligned accesses in hybiReadAndDecode.
10-03-2022 - 15:23 17-06-2020 - 16:15
CVE-2020-14397 5.0
An issue was discovered in LibVNCServer before 0.9.13. libvncserver/rfbregion.c has a NULL pointer dereference.
10-03-2022 - 15:14 17-06-2020 - 16:15
CVE-2020-14398 5.0
An issue was discovered in LibVNCServer before 0.9.13. An improperly closed TCP connection causes an infinite loop in libvncclient/sockets.c.
10-03-2022 - 15:13 17-06-2020 - 16:15
CVE-2020-14402 5.5
An issue was discovered in LibVNCServer before 0.9.13. libvncserver/corre.c allows out-of-bounds access via encodings.
09-03-2022 - 22:56 17-06-2020 - 16:15
CVE-2020-14401 6.4
An issue was discovered in LibVNCServer before 0.9.13. libvncserver/scale.c has a pixel_value integer overflow.
09-03-2022 - 22:56 17-06-2020 - 16:15
Back to Top Mark selected
Back to Top