ID CVE-2022-32285
Summary A vulnerability has been identified in Mendix SAML Module (Mendix 7 compatible) (All versions < V1.16.6), Mendix SAML Module (Mendix 8 compatible) (All versions < V2.2.2), Mendix SAML Module (Mendix 9 compatible) (All versions < V3.2.3). The affected module is vulnerable to XML External Entity (XXE) attacks due to insufficient input sanitation. This may allow an attacker to disclose confidential data under certain circumstances.
References
Vulnerable Configurations
  • cpe:2.3:a:mendix:saml:3.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:3.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:2.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:2.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:2.1.2:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:2.1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:2.1.3:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:2.1.3:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.0:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.1:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.1.2:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.2:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.3:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.3:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.5:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.5:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.6:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.6:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.6.1:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.6.1:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.7:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.7:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.8:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.8:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.8.1:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.8.1:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.8.2:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.8.2:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.8.3:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.8.3:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.8.4:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.8.4:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.9:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.9:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.9.1:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.9.1:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.9.2:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.9.2:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.9.3:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.9.3:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.9.4:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.9.4:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.9.5:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.9.5:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.10.0:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.10.0:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.10.1:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.10.1:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.10.2:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.10.2:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.10.3:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.10.3:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.10.4:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.10.4:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.11.0:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.11.0:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.12.0:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.12.0:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.12.1:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.12.1:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.13.0:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.13.0:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.15.2:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.15.2:*:*:*:*:*:*:*
  • cpe:2.3:a:mendix:saml:1.15.3:*:*:*:*:*:*:*
    cpe:2.3:a:mendix:saml:1.15.3:*:*:*:*:*:*:*
CVSS
Base: 4.3 (as of 22-06-2022 - 19:41)
Impact:
Exploitability:
CWE CWE-611
CAPEC
  • XML External Entities Blowup
    This attack takes advantage of the entity replacement property of XML where the value of the replacement is a URI. A well-crafted XML document could have the entity refer to a URI that consumes a large amount of resources to create a denial of service condition. This can cause the system to either freeze, crash, or execute arbitrary code depending on the URI.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
cvss-vector via4 AV:N/AC:M/Au:N/C:P/I:N/A:N
Last major update 22-06-2022 - 19:41
Published 14-06-2022 - 10:15
Last modified 22-06-2022 - 19:41
Back to Top