ID CVE-2021-31784
Summary An out-of-bounds write vulnerability exists in the file-reading procedure in Open Design Alliance Drawings SDK before 2021.6 on all supported by ODA platforms in static configuration. This can allow attackers to cause a crash, potentially enabling a denial of service attack (Crash, Exit, or Restart) or possible code execution.
References
Vulnerable Configurations
  • cpe:2.3:a:opendesign:drawings_sdk:-:*:*:*:*:*:*:*
    cpe:2.3:a:opendesign:drawings_sdk:-:*:*:*:*:*:*:*
  • cpe:2.3:a:opendesign:drawings_sdk:2019:update1:*:*:*:*:*:*
    cpe:2.3:a:opendesign:drawings_sdk:2019:update1:*:*:*:*:*:*
CVSS
Base: 7.5 (as of 04-05-2021 - 00:30)
Impact:
Exploitability:
CWE CWE-787
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:P/I:P/A:P
Last major update 04-05-2021 - 00:30
Published 26-04-2021 - 19:15
Last modified 04-05-2021 - 00:30
Back to Top