ID CVE-2021-28587
Summary After Effects versions 18.0 (and earlier) are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:after_effects:-:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:-:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:4.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:4.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:4.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:4.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:4.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:5.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:5.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:5.5:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:5.5:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:5.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:5.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:6.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:6.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:6.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:6.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:7.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:7.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:7.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:7.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:16:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:16:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:16.1.2:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:16.1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:17.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:17.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:17.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:17.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:17.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:17.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:after_effects:18.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:after_effects:18.1:*:*:*:*:*:*:*
  • cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*
    cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*
CVSS
Base: 4.3 (as of 02-07-2021 - 14:27)
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Infiltration of Hardware Development Environment
    An attacker, leveraging the ability to manipulate components of primary support systems and tools within the development and production environments, inserts malicious software within the hardware and/or firmware development environment. The infiltration purpose is to alter developed hardware components in a system destined for deployment at the victim's organization, for the purpose of disruption or further compromise.
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
cvss-vector via4 AV:N/AC:M/Au:N/C:P/I:N/A:N
Last major update 02-07-2021 - 14:27
Published 28-06-2021 - 14:15
Last modified 02-07-2021 - 14:27
Back to Top