ID CVE-2021-26707
Summary The merge-deep library before 3.0.3 for Node.js can be tricked into overwriting properties of Object.prototype or adding new properties to it. These properties are then inherited by every object in the program, thus facilitating prototype-pollution attacks against applications using this library.
References
Vulnerable Configurations
  • cpe:2.3:a:merge-deep_project:merge-deep:0.1.0:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:0.1.0:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:0.1.2:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:0.1.2:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:0.1.3:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:0.1.3:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:0.1.4:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:0.1.4:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:0.1.5:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:0.1.5:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:1.0.0:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:1.0.0:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:1.0.1:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:1.0.1:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:1.0.2:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:1.0.2:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:1.0.3:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:1.0.3:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:2.0.0:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:2.0.0:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:2.0.1:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:2.0.1:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:2.0.2:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:2.0.2:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:3.0.0:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:3.0.0:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:3.0.1:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:3.0.1:*:*:*:*:node.js:*:*
  • cpe:2.3:a:merge-deep_project:merge-deep:3.0.2:*:*:*:*:node.js:*:*
    cpe:2.3:a:merge-deep_project:merge-deep:3.0.2:*:*:*:*:node.js:*:*
  • cpe:2.3:a:netapp:e-series_performance_analyzer:-:*:*:*:*:*:*:*
    cpe:2.3:a:netapp:e-series_performance_analyzer:-:*:*:*:*:*:*:*
CVSS
Base: 7.5 (as of 14-09-2021 - 17:10)
Impact:
Exploitability:
CWE CWE-915
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:P/I:P/A:P
Last major update 14-09-2021 - 17:10
Published 02-06-2021 - 15:15
Last modified 14-09-2021 - 17:10
Back to Top