ID CVE-2020-28587
Summary A specially crafted document can cause the document parser to copy data from a particular record type into a static-sized buffer within an object that is smaller than the size used for the copy, which will cause a heap-based buffer overflow. An attacker can entice the victim to open a document to trigger this vulnerability. This affects SoftMaker Software GmbH SoftMaker Office PlanMaker 2021 (Revision 1014).
References
Vulnerable Configurations
  • cpe:2.3:a:softmaker:planmaker_2021:1014:*:*:*:*:*:*:*
    cpe:2.3:a:softmaker:planmaker_2021:1014:*:*:*:*:*:*:*
CVSS
Base: 6.8 (as of 27-02-2021 - 02:54)
Impact:
Exploitability:
CWE CWE-787
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:P/I:P/A:P
Last major update 27-02-2021 - 02:54
Published 23-02-2021 - 19:15
Last modified 27-02-2021 - 02:54
Back to Top