ID CVE-2019-7961
Summary Adobe Prelude CC versions 8.1 and earlier have an insecure library loading (dll hijacking) vulnerability. Successful exploitation could lead to arbitrary code execution.
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:prelude_cc:-:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:prelude_cc:-:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:prelude_cc:8.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:prelude_cc:8.1:*:*:*:*:*:*:*
CVSS
Base: 6.8 (as of 21-07-2021 - 11:39)
Impact:
Exploitability:
CWE CWE-426
CAPEC
  • Leveraging/Manipulating Configuration File Search Paths
    This pattern of attack sees an adversary load a malicious resource into a program's standard path so that when a known command is executed then the system instead executes the malicious component. The adversary can either modify the search path a program uses, like a PATH variable or classpath, or they can manipulate resources on the path to point to their malicious components. J2EE applications and other component based applications that are built from multiple binaries can have very long list of dependencies to execute. If one of these libraries and/or references is controllable by the attacker then application controls can be circumvented by the attacker.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:P/I:P/A:P
refmap via4
confirm https://helpx.adobe.com/security/products/prelude/apsb19-35.html
Last major update 21-07-2021 - 11:39
Published 14-08-2019 - 15:15
Last modified 21-07-2021 - 11:39
Back to Top