ID CVE-2019-1003099
Summary A missing permission check in Jenkins openid Plugin in the OpenIdSsoSecurityRealm.DescriptorImpl#doValidate form validation method allows attackers with Overall/Read permission to initiate a connection to an attacker-specified server.
References
Vulnerable Configurations
  • cpe:2.3:a:jenkins:openid:-:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:-:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:1.0:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:1.0:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:1.1:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:1.1:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:1.2:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:1.2:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:1.3:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:1.3:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:1.4:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:1.4:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:1.5:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:1.5:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:1.6:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:1.6:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:1.7:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:1.7:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:1.8:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:1.8:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:2.0:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:2.0:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:2.1:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:2.1:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:2.1.1:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:2.1.1:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:2.2:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:2.2:*:*:*:*:jenkins:*:*
  • cpe:2.3:a:jenkins:openid:2.3:*:*:*:*:jenkins:*:*
    cpe:2.3:a:jenkins:openid:2.3:*:*:*:*:jenkins:*:*
CVSS
Base: 4.0 (as of 15-07-2020 - 14:57)
Impact:
Exploitability:
CWE CWE-862
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW SINGLE
Impact
ConfidentialityIntegrityAvailability
NONE PARTIAL NONE
cvss-vector via4 AV:N/AC:L/Au:S/C:N/I:P/A:N
refmap via4
bid 107790
confirm https://jenkins.io/security/advisory/2019-04-03/#SECURITY-1084
mlist [oss-security] 20190413 Re: Multiple vulnerabilities in Jenkins plugins
Last major update 15-07-2020 - 14:57
Published 04-04-2019 - 16:29
Last modified 15-07-2020 - 14:57
Back to Top