ID CVE-2018-2973
Summary Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: JSSE). Supported versions that are affected are Java SE: 6u191, 7u181, 8u172 and 10.0.1; Java SE Embedded: 8u171. Difficult to exploit vulnerability allows unauthenticated attacker with network access via SSL/TLS to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Java SE, Java SE Embedded accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.0 Base Score 5.9 (Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N).
References
Vulnerable Configurations
  • cpe:2.3:a:oracle:jdk:1.6.0:update_191:*:*:*:*:*:*
    cpe:2.3:a:oracle:jdk:1.6.0:update_191:*:*:*:*:*:*
  • cpe:2.3:a:oracle:jdk:1.7.0:update181:*:*:*:*:*:*
    cpe:2.3:a:oracle:jdk:1.7.0:update181:*:*:*:*:*:*
  • cpe:2.3:a:oracle:jdk:1.8.0:update172:*:*:*:*:*:*
    cpe:2.3:a:oracle:jdk:1.8.0:update172:*:*:*:*:*:*
  • cpe:2.3:a:oracle:jdk:10.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:jdk:10.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:oracle:jre:1.6.0:update_191:*:*:*:*:*:*
    cpe:2.3:a:oracle:jre:1.6.0:update_191:*:*:*:*:*:*
  • cpe:2.3:a:oracle:jre:1.7.0:update_181:*:*:*:*:*:*
    cpe:2.3:a:oracle:jre:1.7.0:update_181:*:*:*:*:*:*
  • cpe:2.3:a:oracle:jre:1.8.0:update_172:*:*:*:*:*:*
    cpe:2.3:a:oracle:jre:1.8.0:update_172:*:*:*:*:*:*
  • cpe:2.3:a:oracle:jre:10.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:oracle:jre:10.0.1:*:*:*:*:*:*:*
CVSS
Base: 4.3 (as of 08-09-2020 - 12:59)
Impact:
Exploitability:
CWE NVD-CWE-noinfo
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
NONE PARTIAL NONE
cvss-vector via4 AV:N/AC:M/Au:N/C:N/I:P/A:N
redhat via4
advisories
  • bugzilla
    id 1602146
    title CVE-2018-2940 Oracle JDK: unspecified vulnerability fixed in 6u201, 7u191, 8u181, and 10.0.2 (Libraries)
    oval
    OR
    • comment Red Hat Enterprise Linux must be installed
      oval oval:com.redhat.rhba:tst:20070304026
    • AND
      • comment Red Hat Enterprise Linux 7 is installed
        oval oval:com.redhat.rhba:tst:20150364027
      • OR
        • AND
          • comment java-1.8.0-oracle is earlier than 1:1.8.0.181-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182253001
          • comment java-1.8.0-oracle is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080002
        • AND
          • comment java-1.8.0-oracle-devel is earlier than 1:1.8.0.181-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182253003
          • comment java-1.8.0-oracle-devel is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080004
        • AND
          • comment java-1.8.0-oracle-javafx is earlier than 1:1.8.0.181-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182253005
          • comment java-1.8.0-oracle-javafx is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080006
        • AND
          • comment java-1.8.0-oracle-jdbc is earlier than 1:1.8.0.181-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182253007
          • comment java-1.8.0-oracle-jdbc is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080008
        • AND
          • comment java-1.8.0-oracle-plugin is earlier than 1:1.8.0.181-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182253009
          • comment java-1.8.0-oracle-plugin is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080010
        • AND
          • comment java-1.8.0-oracle-src is earlier than 1:1.8.0.181-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182253011
          • comment java-1.8.0-oracle-src is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080012
    rhsa
    id RHSA-2018:2253
    released 2018-07-24
    severity Critical
    title RHSA-2018:2253: java-1.8.0-oracle security update (Critical)
  • bugzilla
    id 1602146
    title CVE-2018-2940 Oracle JDK: unspecified vulnerability fixed in 6u201, 7u191, 8u181, and 10.0.2 (Libraries)
    oval
    OR
    • comment Red Hat Enterprise Linux must be installed
      oval oval:com.redhat.rhba:tst:20070304026
    • AND
      • comment Red Hat Enterprise Linux 7 is installed
        oval oval:com.redhat.rhba:tst:20150364027
      • OR
        • AND
          • comment java-1.7.0-oracle is earlier than 1:1.7.0.191-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182254001
          • comment java-1.7.0-oracle is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413015
        • AND
          • comment java-1.7.0-oracle-devel is earlier than 1:1.7.0.191-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182254003
          • comment java-1.7.0-oracle-devel is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413017
        • AND
          • comment java-1.7.0-oracle-javafx is earlier than 1:1.7.0.191-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182254005
          • comment java-1.7.0-oracle-javafx is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413019
        • AND
          • comment java-1.7.0-oracle-jdbc is earlier than 1:1.7.0.191-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182254007
          • comment java-1.7.0-oracle-jdbc is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413021
        • AND
          • comment java-1.7.0-oracle-plugin is earlier than 1:1.7.0.191-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182254009
          • comment java-1.7.0-oracle-plugin is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413023
        • AND
          • comment java-1.7.0-oracle-src is earlier than 1:1.7.0.191-1jpp.2.el7
            oval oval:com.redhat.rhsa:tst:20182254011
          • comment java-1.7.0-oracle-src is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413025
    rhsa
    id RHSA-2018:2254
    released 2018-07-24
    severity Critical
    title RHSA-2018:2254: java-1.7.0-oracle security update (Critical)
  • bugzilla
    id 1602146
    title CVE-2018-2940 Oracle JDK: unspecified vulnerability fixed in 6u201, 7u191, 8u181, and 10.0.2 (Libraries)
    oval
    OR
    • comment Red Hat Enterprise Linux must be installed
      oval oval:com.redhat.rhba:tst:20070304026
    • AND
      • comment Red Hat Enterprise Linux 6 is installed
        oval oval:com.redhat.rhba:tst:20111656003
      • OR
        • AND
          • comment java-1.7.0-oracle is earlier than 1:1.7.0.191-1jpp.1.el6
            oval oval:com.redhat.rhsa:tst:20182255001
          • comment java-1.7.0-oracle is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413015
        • AND
          • comment java-1.7.0-oracle-devel is earlier than 1:1.7.0.191-1jpp.1.el6
            oval oval:com.redhat.rhsa:tst:20182255003
          • comment java-1.7.0-oracle-devel is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413017
        • AND
          • comment java-1.7.0-oracle-javafx is earlier than 1:1.7.0.191-1jpp.1.el6
            oval oval:com.redhat.rhsa:tst:20182255005
          • comment java-1.7.0-oracle-javafx is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413019
        • AND
          • comment java-1.7.0-oracle-jdbc is earlier than 1:1.7.0.191-1jpp.1.el6
            oval oval:com.redhat.rhsa:tst:20182255007
          • comment java-1.7.0-oracle-jdbc is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413021
        • AND
          • comment java-1.7.0-oracle-plugin is earlier than 1:1.7.0.191-1jpp.1.el6
            oval oval:com.redhat.rhsa:tst:20182255009
          • comment java-1.7.0-oracle-plugin is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413023
        • AND
          • comment java-1.7.0-oracle-src is earlier than 1:1.7.0.191-1jpp.1.el6
            oval oval:com.redhat.rhsa:tst:20182255011
          • comment java-1.7.0-oracle-src is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20140413025
    rhsa
    id RHSA-2018:2255
    released 2018-07-24
    severity Critical
    title RHSA-2018:2255: java-1.7.0-oracle security update (Critical)
  • bugzilla
    id 1602146
    title CVE-2018-2940 Oracle JDK: unspecified vulnerability fixed in 6u201, 7u191, 8u181, and 10.0.2 (Libraries)
    oval
    OR
    • comment Red Hat Enterprise Linux must be installed
      oval oval:com.redhat.rhba:tst:20070304026
    • AND
      • comment Red Hat Enterprise Linux 6 is installed
        oval oval:com.redhat.rhba:tst:20111656003
      • OR
        • AND
          • comment java-1.8.0-oracle is earlier than 1:1.8.0.181-1jpp.2.el6
            oval oval:com.redhat.rhsa:tst:20182256001
          • comment java-1.8.0-oracle is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080002
        • AND
          • comment java-1.8.0-oracle-devel is earlier than 1:1.8.0.181-1jpp.2.el6
            oval oval:com.redhat.rhsa:tst:20182256003
          • comment java-1.8.0-oracle-devel is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080004
        • AND
          • comment java-1.8.0-oracle-javafx is earlier than 1:1.8.0.181-1jpp.2.el6
            oval oval:com.redhat.rhsa:tst:20182256005
          • comment java-1.8.0-oracle-javafx is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080006
        • AND
          • comment java-1.8.0-oracle-jdbc is earlier than 1:1.8.0.181-1jpp.2.el6
            oval oval:com.redhat.rhsa:tst:20182256007
          • comment java-1.8.0-oracle-jdbc is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080008
        • AND
          • comment java-1.8.0-oracle-plugin is earlier than 1:1.8.0.181-1jpp.2.el6
            oval oval:com.redhat.rhsa:tst:20182256009
          • comment java-1.8.0-oracle-plugin is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080010
        • AND
          • comment java-1.8.0-oracle-src is earlier than 1:1.8.0.181-1jpp.2.el6
            oval oval:com.redhat.rhsa:tst:20182256011
          • comment java-1.8.0-oracle-src is signed with Red Hat redhatrelease2 key
            oval oval:com.redhat.rhsa:tst:20150080012
    rhsa
    id RHSA-2018:2256
    released 2018-07-24
    severity Critical
    title RHSA-2018:2256: java-1.8.0-oracle security update (Critical)
  • rhsa
    id RHSA-2018:2568
  • rhsa
    id RHSA-2018:2569
  • rhsa
    id RHSA-2018:2575
  • rhsa
    id RHSA-2018:2576
  • rhsa
    id RHSA-2018:2712
  • rhsa
    id RHSA-2018:2713
  • rhsa
    id RHSA-2018:3007
  • rhsa
    id RHSA-2018:3008
rpms
  • java-1.8.0-oracle-1:1.8.0.181-1jpp.2.el7
  • java-1.8.0-oracle-devel-1:1.8.0.181-1jpp.2.el7
  • java-1.8.0-oracle-javafx-1:1.8.0.181-1jpp.2.el7
  • java-1.8.0-oracle-jdbc-1:1.8.0.181-1jpp.2.el7
  • java-1.8.0-oracle-plugin-1:1.8.0.181-1jpp.2.el7
  • java-1.8.0-oracle-src-1:1.8.0.181-1jpp.2.el7
  • java-1.7.0-oracle-1:1.7.0.191-1jpp.2.el7
  • java-1.7.0-oracle-devel-1:1.7.0.191-1jpp.2.el7
  • java-1.7.0-oracle-javafx-1:1.7.0.191-1jpp.2.el7
  • java-1.7.0-oracle-jdbc-1:1.7.0.191-1jpp.2.el7
  • java-1.7.0-oracle-plugin-1:1.7.0.191-1jpp.2.el7
  • java-1.7.0-oracle-src-1:1.7.0.191-1jpp.2.el7
  • java-1.7.0-oracle-1:1.7.0.191-1jpp.1.el6
  • java-1.7.0-oracle-devel-1:1.7.0.191-1jpp.1.el6
  • java-1.7.0-oracle-javafx-1:1.7.0.191-1jpp.1.el6
  • java-1.7.0-oracle-jdbc-1:1.7.0.191-1jpp.1.el6
  • java-1.7.0-oracle-plugin-1:1.7.0.191-1jpp.1.el6
  • java-1.7.0-oracle-src-1:1.7.0.191-1jpp.1.el6
  • java-1.8.0-oracle-1:1.8.0.181-1jpp.2.el6
  • java-1.8.0-oracle-devel-1:1.8.0.181-1jpp.2.el6
  • java-1.8.0-oracle-javafx-1:1.8.0.181-1jpp.2.el6
  • java-1.8.0-oracle-jdbc-1:1.8.0.181-1jpp.2.el6
  • java-1.8.0-oracle-plugin-1:1.8.0.181-1jpp.2.el6
  • java-1.8.0-oracle-src-1:1.8.0.181-1jpp.2.el6
  • java-1.8.0-ibm-1:1.8.0.5.20-1jpp.1.el7
  • java-1.8.0-ibm-demo-1:1.8.0.5.20-1jpp.1.el7
  • java-1.8.0-ibm-devel-1:1.8.0.5.20-1jpp.1.el7
  • java-1.8.0-ibm-jdbc-1:1.8.0.5.20-1jpp.1.el7
  • java-1.8.0-ibm-plugin-1:1.8.0.5.20-1jpp.1.el7
  • java-1.8.0-ibm-src-1:1.8.0.5.20-1jpp.1.el7
  • java-1.7.1-ibm-1:1.7.1.4.30-1jpp.1.el7
  • java-1.7.1-ibm-demo-1:1.7.1.4.30-1jpp.1.el7
  • java-1.7.1-ibm-devel-1:1.7.1.4.30-1jpp.1.el7
  • java-1.7.1-ibm-jdbc-1:1.7.1.4.30-1jpp.1.el7
  • java-1.7.1-ibm-plugin-1:1.7.1.4.30-1jpp.1.el7
  • java-1.7.1-ibm-src-1:1.7.1.4.30-1jpp.1.el7
  • java-1.8.0-ibm-1:1.8.0.5.20-1jpp.1.el6_10
  • java-1.8.0-ibm-demo-1:1.8.0.5.20-1jpp.1.el6_10
  • java-1.8.0-ibm-devel-1:1.8.0.5.20-1jpp.1.el6_10
  • java-1.8.0-ibm-jdbc-1:1.8.0.5.20-1jpp.1.el6_10
  • java-1.8.0-ibm-plugin-1:1.8.0.5.20-1jpp.1.el6_10
  • java-1.8.0-ibm-src-1:1.8.0.5.20-1jpp.1.el6_10
  • java-1.7.1-ibm-1:1.7.1.4.30-1jpp.2.el6_10
  • java-1.7.1-ibm-demo-1:1.7.1.4.30-1jpp.2.el6_10
  • java-1.7.1-ibm-devel-1:1.7.1.4.30-1jpp.2.el6_10
  • java-1.7.1-ibm-jdbc-1:1.7.1.4.30-1jpp.2.el6_10
  • java-1.7.1-ibm-plugin-1:1.7.1.4.30-1jpp.2.el6_10
  • java-1.7.1-ibm-src-1:1.7.1.4.30-1jpp.2.el6_10
  • java-1.7.1-ibm-1:1.7.1.4.30-1jpp.2.el6_10
  • java-1.7.1-ibm-devel-1:1.7.1.4.30-1jpp.2.el6_10
  • java-1.8.0-ibm-1:1.8.0.5.20-1jpp.1.el6_10
  • java-1.8.0-ibm-devel-1:1.8.0.5.20-1jpp.1.el6_10
  • java-1.6.0-sun-1:1.6.0.211-1jpp.1.el7
  • java-1.6.0-sun-demo-1:1.6.0.211-1jpp.1.el7
  • java-1.6.0-sun-devel-1:1.6.0.211-1jpp.1.el7
  • java-1.6.0-sun-jdbc-1:1.6.0.211-1jpp.1.el7
  • java-1.6.0-sun-plugin-1:1.6.0.211-1jpp.1.el7
  • java-1.6.0-sun-src-1:1.6.0.211-1jpp.1.el7
  • java-1.6.0-sun-1:1.6.0.211-1jpp.1.el6
  • java-1.6.0-sun-demo-1:1.6.0.211-1jpp.1.el6
  • java-1.6.0-sun-devel-1:1.6.0.211-1jpp.1.el6
  • java-1.6.0-sun-jdbc-1:1.6.0.211-1jpp.1.el6
  • java-1.6.0-sun-plugin-1:1.6.0.211-1jpp.1.el6
  • java-1.6.0-sun-src-1:1.6.0.211-1jpp.1.el6
refmap via4
bid 104773
confirm
sectrack 1041302
Last major update 08-09-2020 - 12:59
Published 18-07-2018 - 13:29
Last modified 08-09-2020 - 12:59
Back to Top