ID CVE-2018-12826
Summary Adobe Flash Player 30.0.0.134 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:*:*:*:*:*:chrome:*:*
    cpe:2.3:a:adobe:flash_player:*:*:*:*:*:chrome:*:*
  • cpe:2.3:a:adobe:flash_player:*:*:*:*:*:edge:*:*
    cpe:2.3:a:adobe:flash_player:*:*:*:*:*:edge:*:*
  • cpe:2.3:a:adobe:flash_player:*:*:*:*:*:internet_explorer_11:*:*
    cpe:2.3:a:adobe:flash_player:*:*:*:*:*:internet_explorer_11:*:*
  • cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:*
    cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:*
  • cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:*
    cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:*
  • cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:*
    cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 30-10-2018 - 14:59)
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
assigner via4 cve@mitre.org
cvss-vector via4 AV:N/AC:L/Au:N/C:P/I:N/A:N
non_vulnerable_configuration via4
  • cpe:2.3:o:apple:mac_os_x:-:*:*:*:*:*:*:*
  • cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:mac_os_x:-:*:*:*:*:*:*:*
  • cpe:2.3:o:google:chrome_os:-:*:*:*:*:*:*:*
  • cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:*
  • cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*
  • cpe:2.3:o:microsoft:windows_10:-:*:*:*:*:*:*:*
  • cpe:2.3:o:microsoft:windows_8.1:-:*:*:*:*:*:*:*
redhat via4
advisories
rhsa
id RHSA-2018:2435
refmap via4
bid 105066
confirm https://helpx.adobe.com/security/products/flash-player/apsb18-25.html
sectrack 1041448
vulnerable_product via4
    Last major update 30-10-2018 - 14:59
    Published 29-08-2018 - 13:29
    Back to Top