ID CVE-2018-12449
Summary The Whale browser installer 0.4.3.0 and earlier versions allows DLL hijacking.
References
Vulnerable Configurations
  • cpe:2.3:a:navercorp:whale:0.4.3.0
    cpe:2.3:a:navercorp:whale:0.4.3.0
CVSS
Base: 6.8
Impact:
Exploitability:
CWE CWE-426
CAPEC
  • Leveraging/Manipulating Configuration File Search Paths
    This attack loads a malicious resource into a program's standard path used to bootstrap and/or provide contextual information for a program like a path variable or classpath. J2EE applications and other component based applications that are built from multiple binaries can have very long list of dependencies to execute. If one of these libraries and/or references is controllable by the attacker then application controls can be circumvented by the attacker. A standard UNIX path looks similar to this If the attacker modifies the path variable to point to a locale that includes malicious resources then the user unwittingly can execute commands on the attackers' behalf: This is a form of usurping control of the program and the attack can be done on the classpath, database resources, or any other resources built from compound parts. At runtime detection and blocking of this attack is nearly impossible, because the configuration allows execution.
refmap via4
confirm https://cve.naver.com/detail/cve-2018-12449
Last major update 11-10-2018 - 09:29
Published 11-10-2018 - 09:29
Last modified 20-11-2018 - 14:43
Back to Top