ID CVE-2013-4389
Summary Multiple format string vulnerabilities in log_subscriber.rb files in the log subscriber component in Action Mailer in Ruby on Rails 3.x before 3.2.15 allow remote attackers to cause a denial of service via a crafted e-mail address that is improperly handled during construction of a log message.
References
Vulnerable Configurations
  • cpe:2.3:a:rubyonrails:rails:3.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.5:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.5:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.6:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.6:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.7:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.7:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.8:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.8:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.9:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.9:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.10:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.10:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.11:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.11:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.12:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.12:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.13:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.13:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.14:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.14:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.16:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.16:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.17:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.17:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.18:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.18:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.19:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.19:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.0.20:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.0.20:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.0:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.2:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.3:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.3:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.4:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.4:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.5:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.5:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.6:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.6:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.7:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.7:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.8:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.8:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.9:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.9:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.1.10:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.1.10:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.0:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.2:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.3:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.4:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.4:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.5:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.6:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.6:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.7:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.7:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.8:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.8:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.9:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.9:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.10:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.10:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.11:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.11:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.12:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.12:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:rails:3.2.13:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:rails:3.2.13:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:rubyonrails:ruby_on_rails:3.2.14:*:*:*:*:*:*:*
    cpe:2.3:a:rubyonrails:ruby_on_rails:3.2.14:*:*:*:*:*:*:*
CVSS
Base: 4.3 (as of 08-08-2019 - 15:42)
Impact:
Exploitability:
CWE CWE-134
CAPEC
  • String Format Overflow in syslog()
    This attack targets the format string vulnerabilities in the syslog() function. An attacker would typically inject malicious input in the format string parameter of the syslog function. This is a common problem, and many public vulnerabilities and associated exploits have been posted.
  • Format String Injection
    An adversary includes formatting characters in a string input field on the target application. Most applications assume that users will provide static text and may respond unpredictably to the presence of formatting character. For example, in certain functions of the C programming languages such as printf, the formatting character %s will print the contents of a memory location expecting this location to identify a string and the formatting character %n prints the number of DWORD written in the memory. An adversary can use this to read or write to memory locations or files, or simply to manipulate the value of the resulting text in unexpected ways. Reading or writing memory may result in program crashes and writing memory could result in the execution of arbitrary code if the adversary can write to the program stack.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:N/I:N/A:P
redhat via4
rpms
  • cfme-0:5.4.0.5-1.el6cf
  • cfme-appliance-0:5.4.0.5-1.el6cf
  • cfme-debuginfo-0:5.4.0.5-1.el6cf
  • cfme-gemset-0:5.4.0.5-1.el6cf
  • cfme-lib-0:5.4.0.5-1.el6cf
  • cfme-vnc-plugin-0:1.0.0-2.el6cf
  • cfme-vnc-plugin-debuginfo-0:1.0.0-2.el6cf
  • libdnet-0:1.12-11.el6cf
  • libdnet-debuginfo-0:1.12-11.el6cf
  • libdnet-devel-0:1.12-11.el6cf
  • libdnet-progs-0:1.12-11.el6cf
  • lshw-0:B.02.16-4.el6cf
  • lshw-debuginfo-0:B.02.16-4.el6cf
  • lshw-gui-0:B.02.16-4.el6cf
  • netapp-manageability-sdk-0:4.0P1-3.el6cf
  • netapp-manageability-sdk-devel-0:4.0P1-3.el6cf
  • open-vm-tools-0:9.2.3-5.el6cf
  • open-vm-tools-debuginfo-0:9.2.3-5.el6cf
  • open-vm-tools-desktop-0:9.2.3-5.el6cf
  • open-vm-tools-devel-0:9.2.3-5.el6cf
  • prince-0:9.0r2-4.el6cf
  • pyliblzma-0:0.5.3-7.el6cf
  • pyliblzma-debuginfo-0:0.5.3-7.el6cf
  • ruby200-rubygem-bcrypt-ruby-0:3.0.1-2.el6cf
  • ruby200-rubygem-bcrypt-ruby-debuginfo-0:3.0.1-2.el6cf
  • ruby200-rubygem-eventmachine-0:1.0.7-2.el6cf
  • ruby200-rubygem-eventmachine-debuginfo-0:1.0.7-2.el6cf
  • ruby200-rubygem-ffi-0:1.9.8-1.el6cf
  • ruby200-rubygem-ffi-debuginfo-0:1.9.8-1.el6cf
  • ruby200-rubygem-io-extra-0:1.2.8-1.el6cf
  • ruby200-rubygem-io-extra-debuginfo-0:1.2.8-1.el6cf
  • ruby200-rubygem-json-0:1.8.2-2.el6cf
  • ruby200-rubygem-json-debuginfo-0:1.8.2-2.el6cf
  • ruby200-rubygem-nokogiri-0:1.5.11-2.el6cf
  • ruby200-rubygem-nokogiri-debuginfo-0:1.5.11-2.el6cf
  • ruby200-rubygem-pg-0:0.12.2-9.el6cf
  • ruby200-rubygem-pg-debuginfo-0:0.12.2-9.el6cf
  • ruby200-rubygem-psych-0:2.0.13-1.el6cf
  • ruby200-rubygem-psych-debuginfo-0:2.0.13-1.el6cf
  • ruby200-rubygem-qpid_messaging-0:0.20.2-5.el6cf
  • ruby200-rubygem-qpid_messaging-debuginfo-0:0.20.2-5.el6cf
  • ruby200-rubygem-therubyracer-0:0.11.0-5.el6cf
  • ruby200-rubygem-therubyracer-debuginfo-0:0.11.0-5.el6cf
  • ruby200-rubygem-thin-0:1.3.1-9.el6cf
  • ruby200-rubygem-thin-debuginfo-0:1.3.1-9.el6cf
  • sneakernet_ca-0:0.1-2.el6cf
  • wmi-0:1.3.14-1.el6cf
  • wmi-debuginfo-0:1.3.14-1.el6cf
refmap via4
debian
  • DSA-2887
  • DSA-2888
mlist [ruby-security-ann] 20131016 Possible DoS Vulnerability in Action Mailer (CVE-2013-4389)
suse
  • openSUSE-SU-2013:1928
  • openSUSE-SU-2013:1931
  • openSUSE-SU-2014:0009
Last major update 08-08-2019 - 15:42
Published 17-10-2013 - 00:55
Last modified 08-08-2019 - 15:42
Back to Top