ID CVE-2010-3710
Summary Stack consumption vulnerability in the filter_var function in PHP 5.2.x through 5.2.14 and 5.3.x through 5.3.3, when FILTER_VALIDATE_EMAIL mode is used, allows remote attackers to cause a denial of service (memory consumption and application crash) via a long e-mail address string.
References
Vulnerable Configurations
  • cpe:2.3:a:php:php:5.2.0:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.2:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.3:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.4:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.4:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.5:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.6:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.6:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.7:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.7:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.8:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.8:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.9:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.9:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.10:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.10:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.11:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.11:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.12:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.12:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.13:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.13:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.2.14:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.2.14:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.3.0:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.3.0:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.3.1:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.3.1:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.3.2:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.3.2:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:5.3.3:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:5.3.3:*:*:*:*:*:*:*
CVSS
Base: 4.3 (as of 23-08-2016 - 02:02)
Impact:
Exploitability:
CWE CWE-399
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:N/I:N/A:P
redhat via4
advisories
rhsa
id RHSA-2011:0196
rpms
  • php53-0:5.3.3-1.el5_6.1
  • php53-bcmath-0:5.3.3-1.el5_6.1
  • php53-cli-0:5.3.3-1.el5_6.1
  • php53-common-0:5.3.3-1.el5_6.1
  • php53-dba-0:5.3.3-1.el5_6.1
  • php53-devel-0:5.3.3-1.el5_6.1
  • php53-gd-0:5.3.3-1.el5_6.1
  • php53-imap-0:5.3.3-1.el5_6.1
  • php53-intl-0:5.3.3-1.el5_6.1
  • php53-ldap-0:5.3.3-1.el5_6.1
  • php53-mbstring-0:5.3.3-1.el5_6.1
  • php53-mysql-0:5.3.3-1.el5_6.1
  • php53-odbc-0:5.3.3-1.el5_6.1
  • php53-pdo-0:5.3.3-1.el5_6.1
  • php53-pgsql-0:5.3.3-1.el5_6.1
  • php53-process-0:5.3.3-1.el5_6.1
  • php53-pspell-0:5.3.3-1.el5_6.1
  • php53-snmp-0:5.3.3-1.el5_6.1
  • php53-soap-0:5.3.3-1.el5_6.1
  • php53-xml-0:5.3.3-1.el5_6.1
  • php53-xmlrpc-0:5.3.3-1.el5_6.1
refmap via4
apple APPLE-SA-2011-03-21-1
bid 43926
confirm
fedora
  • FEDORA-2010-18976
  • FEDORA-2010-19011
hp
  • HPSBOV02763
  • SSRT100826
mandriva MDVSA-2010:218
secunia
  • 42812
  • 43189
suse SUSE-SR:2010:023
ubuntu USN-1042-1
vupen
  • ADV-2011-0020
  • ADV-2011-0021
  • ADV-2011-0077
Last major update 23-08-2016 - 02:02
Published 25-10-2010 - 20:01
Back to Top