ID CVE-2009-3707
Summary VMware Authentication Daemon 1.0 in vmware-authd.exe in the VMware Authorization Service in VMware Workstation 7.0 before 7.0.1 build 227600 and 6.5.x before 6.5.4 build 246459, VMware Player 3.0 before 3.0.1 build 227600 and 2.5.x before 2.5.4 build 246459, VMware ACE 2.6 before 2.6.1 build 227600 and 2.5.x before 2.5.4 build 246459, and VMware Server 2.x allows remote attackers to cause a denial of service (process crash) via a \x25\xFF sequence in the USER and PASS commands, related to a "format string DoS" issue. NOTE: some of these details are obtained from third party information.
References
Vulnerable Configurations
  • cpe:2.3:a:vmware:ace:2.5.0:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:ace:2.5.0:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:ace:2.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:ace:2.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:ace:2.5.2:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:ace:2.5.2:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:ace:2.5.3:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:ace:2.5.3:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:ace:2.5.4:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:ace:2.5.4:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:ace:2.6:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:ace:2.6:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:ace:2.6.1:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:ace:2.6.1:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:player:2.5:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:player:2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:player:2.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:player:2.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:player:2.5.2:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:player:2.5.2:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:player:2.5.3:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:player:2.5.3:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:player:2.5.4:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:player:2.5.4:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:player:3.0:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:player:3.0:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:player:3.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:player:3.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:server:2.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:server:2.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:server:2.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:server:2.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:server:2.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:server:2.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:workstation:6.5.0:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:workstation:6.5.0:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:workstation:6.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:workstation:6.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:workstation:6.5.2:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:workstation:6.5.2:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:workstation:6.5.3:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:workstation:6.5.3:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:workstation:6.5.4:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:workstation:6.5.4:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:workstation:7.0:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:workstation:7.0:*:*:*:*:*:*:*
  • cpe:2.3:a:vmware:workstation:7.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:vmware:workstation:7.0.1:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 15-05-2013 - 03:01)
Impact:
Exploitability:
CWE CWE-134
CAPEC
  • Format String Injection
    An adversary includes formatting characters in a string input field on the target application. Most applications assume that users will provide static text and may respond unpredictably to the presence of formatting character. For example, in certain functions of the C programming languages such as printf, the formatting character %s will print the contents of a memory location expecting this location to identify a string and the formatting character %n prints the number of DWORD written in the memory. An adversary can use this to read or write to memory locations or files, or simply to manipulate the value of the resulting text in unexpected ways. Reading or writing memory may result in program crashes and writing memory could result in the execution of arbitrary code if the adversary can write to the program stack.
  • String Format Overflow in syslog()
    This attack targets the format string vulnerabilities in the syslog() function. An attacker would typically inject malicious input in the format string parameter of the syslog function. This is a common problem, and many public vulnerabilities and associated exploits have been posted.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:P
refmap via4
bid 36630
bugtraq 20100409 VMSA-2010-0007 VMware hosted products, vCenter Server and ESX patches resolve multiple security issues
confirm http://www.vmware.com/security/advisories/VMSA-2010-0007.html
fulldisc 20100409 VMSA-2010-0007 VMware hosted products, vCenter Server and ESX patches resolve multiple security issues
gentoo GLSA-201209-25
misc
mlist [security-announce] 20100409 VMSA-2010-0007 VMware hosted products, vCenter Server and ESX patches resolve multiple security issues
sectrack 1022997
secunia
  • 36988
  • 39206
  • 39215
Last major update 15-05-2013 - 03:01
Published 16-10-2009 - 16:30
Back to Top