ID CVE-2007-1412
Summary The cpdf_open function in the ClibPDF (cpdf) extension in PHP 4.4.6 allows context-dependent attackers to obtain sensitive information (script source code) via a long string in the second argument.
References
Vulnerable Configurations
  • cpe:2.3:a:php:php:4.4.6:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:4.4.6:*:*:*:*:*:*:*
CVSS
Base: 7.8 (as of 11-10-2017 - 01:31)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE NONE NONE
cvss-vector via4 AV:N/AC:L/Au:N/C:C/I:N/A:N
refmap via4
bid 22897
exploit-db 3442
xf php-clibpdf-source-disclosure(32986)
statements via4
contributor Mark J Cox
lastmodified 2007-03-19
organization Red Hat
statement Not vulnerable. PHP as shipped with Red Hat Enterprise Linux 2.1, 3, 4, and 5 does not include ClibPDF support.
Last major update 11-10-2017 - 01:31
Published 12-03-2007 - 23:19
Back to Top