ID CVE-2007-1401
Summary Buffer overflow in the crack extension (CrackLib), as bundled with PHP 4.4.6 and other versions before 5.0.0, might allow local users to gain privileges via a long argument to the crack_opendict function.
References
Vulnerable Configurations
  • cpe:2.3:a:php:php:4.4.6:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:4.4.6:*:*:*:*:*:*:*
CVSS
Base: 6.9 (as of 16-10-2018 - 16:38)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
LOCAL MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
cvss-vector via4 AV:L/AC:M/Au:N/C:C/I:C/A:C
refmap via4
bugtraq 20070308 PHP 4.4.6 crack_opendict() local buffer overflow poc exploit
exploit-db 3431
misc http://retrogod.altervista.org/php_446_crack_opendict_local_bof.html
sreason 2405
statements via4
contributor Mark J Cox
lastmodified 2007-03-19
organization Red Hat
statement Not vulnerable. PHP as shipped with Red Hat Enterprise Linux 2.1, 3, 4, and 5 does not include Cracklib support.
Last major update 16-10-2018 - 16:38
Published 10-03-2007 - 22:19
Back to Top