ID CVE-2000-0499
Summary The default configuration of BEA WebLogic 3.1.8 through 4.5.1 allows a remote attacker to view source code of a JSP program by requesting a URL which provides the JSP extension in upper case.
References
Vulnerable Configurations
  • cpe:2.3:a:bea:weblogic_server:*:*:express:*:*:*:*:*
    cpe:2.3:a:bea:weblogic_server:*:*:express:*:*:*:*:*
  • cpe:2.3:a:bea:weblogic_server:3.1.8:*:*:*:*:*:*:*
    cpe:2.3:a:bea:weblogic_server:3.1.8:*:*:*:*:*:*:*
  • cpe:2.3:a:bea:weblogic_server:4.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:bea:weblogic_server:4.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:bea:weblogic_server:4.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:bea:weblogic_server:4.5.1:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 10-10-2017 - 01:29)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
cvss-vector via4 AV:N/AC:L/Au:N/C:P/I:N/A:N
refmap via4
bid 1328
confirm http://developer.bea.com/alerts/security_000612.html
ntbugtraq 20000612 BEA WebLogic JSP showcode vulnerability
xf weblogic-jsp-source-read(4694)
Last major update 10-10-2017 - 01:29
Published 08-06-2000 - 04:00
Last modified 10-10-2017 - 01:29
Back to Top