ID CVE-2021-27803
Summary A vulnerability was discovered in how p2p/p2p_pd.c in wpa_supplicant before 2.10 processes P2P (Wi-Fi Direct) provision discovery requests. It could result in denial of service or other impact (potentially execution of arbitrary code), for an attacker within radio range.
References
Vulnerable Configurations
  • cpe:2.3:a:w1.fi:wpa_supplicant:1.0:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:1.1:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.0:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.0-16:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.0-16:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.1:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.2:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.3:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.4:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.4:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.5:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.6:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.6:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.7:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.7:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.8:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.8:*:*:*:*:*:*:*
  • cpe:2.3:a:w1.fi:wpa_supplicant:2.9:*:*:*:*:*:*:*
    cpe:2.3:a:w1.fi:wpa_supplicant:2.9:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
CVSS
Base: 5.4 (as of 23-03-2021 - 01:06)
Impact:
Exploitability:
CWE NVD-CWE-noinfo
CAPEC
Access
VectorComplexityAuthentication
ADJACENT_NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:A/AC:M/Au:N/C:P/I:P/A:P
Last major update 23-03-2021 - 01:06
Published 26-02-2021 - 23:15
Last modified 23-03-2021 - 01:06
Back to Top