ID CVE-2020-6851
Summary OpenJPEG through 2.3.1 has a heap-based buffer overflow in opj_t1_clbl_decode_processor in openjp2/t1.c because of lack of opj_j2k_update_image_dimensions validation.
References
Vulnerable Configurations
  • cpe:2.3:a:openjpeg:openjpeg:-:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:-:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:1.3:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:1.3:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:1.4:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:1.4:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:1.5:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:1.5:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:1.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:1.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:1.5.2:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:1.5.2:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:2.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:2.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:2.1.0:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:2.1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:2.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:2.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:2.1.2:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:2.1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:openjpeg:openjpeg:2.3.1:*:*:*:*:*:*:*
    cpe:2.3:a:openjpeg:openjpeg:2.3.1:*:*:*:*:*:*:*
CVSS
Base: 5.0
Impact:
Exploitability:
CWE CWE-787
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
Last major update 13-01-2020 - 06:15
Published 13-01-2020 - 06:15
Last modified 28-01-2020 - 18:15
Back to Top