ID CVE-2020-3384
Summary A vulnerability in specific REST API endpoints of Cisco Data Center Network Manager (DCNM) could allow an authenticated, remote attacker to inject arbitrary commands on the underlying operating system with the privileges of the logged-in user. The vulnerability is due to insufficient validation of user-supplied input to the API. An attacker could exploit this vulnerability by sending a crafted request to the API. A successful exploit could allow the attacker to inject arbitrary commands on the underlying operating system.
References
Vulnerable Configurations
  • cpe:2.3:a:cisco:data_center_network_manager:4.0:*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:4.0:*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:4.1:*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:4.2:*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:4.2:*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:5.0:*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:5.0:*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:10.0:*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:10.0:*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:10.1:*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:10.1:*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:10.2\(1\):*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:10.2\(1\):*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:10.3\(1\):*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:10.3\(1\):*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:10.4\(1\):*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:10.4\(1\):*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:10.4\(2\):*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:10.4\(2\):*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:11.0\(1\):*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:11.0\(1\):*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:11.1\(1\):*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:11.1\(1\):*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:11.2\(1\):*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:11.2\(1\):*:*:*:*:*:*:*
  • cpe:2.3:a:cisco:data_center_network_manager:11.3\(1\):*:*:*:*:*:*:*
    cpe:2.3:a:cisco:data_center_network_manager:11.3\(1\):*:*:*:*:*:*:*
CVSS
Base: 6.0
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM SINGLE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
Last major update 31-07-2020 - 01:15
Published 31-07-2020 - 00:15
Last modified 05-08-2020 - 14:13
Back to Top