ID CVE-2018-5241
Summary Symantec Advanced Secure Gateway (ASG) 6.6 and 6.7, and ProxySG 6.5, 6.6, and 6.7 are susceptible to a SAML authentication bypass vulnerability. The products can be configured with a SAML authentication realm to authenticate network users in intercepted proxy traffic. When parsing SAML responses, ASG and ProxySG incorrectly handle XML nodes with comments. A remote attacker can modify a valid SAML response without invalidating its cryptographic signature. This may allow the attacker to bypass user authentication security controls in ASG and ProxySG. This vulnerability only affects authentication of network users in intercepted traffic. It does not affect administrator user authentication for the ASG and ProxySG management consoles.
References
Vulnerable Configurations
  • cpe:2.3:a:symantec:advanced_secure_gateway:6.6
    cpe:2.3:a:symantec:advanced_secure_gateway:6.6
  • cpe:2.3:a:symantec:advanced_secure_gateway:6.7
    cpe:2.3:a:symantec:advanced_secure_gateway:6.7
  • cpe:2.3:a:symantec:proxysg:6.5
    cpe:2.3:a:symantec:proxysg:6.5
  • cpe:2.3:a:symantec:proxysg:6.6
    cpe:2.3:a:symantec:proxysg:6.6
  • cpe:2.3:a:symantec:proxysg:6.7
    cpe:2.3:a:symantec:proxysg:6.7
CVSS
Base: 7.5
Impact:
Exploitability:
CWE CWE-254
CAPEC
refmap via4
bid 104282
confirm https://www.symantec.com/security-center/network-protection-security-advisories/SA167
sectrack 1040993
Last major update 29-05-2018 - 09:29
Published 29-05-2018 - 09:29
Last modified 09-07-2018 - 10:13
Back to Top