ID CVE-2018-5008
Summary Adobe Flash Player 30.0.0.113 and earlier versions have an Out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:flash_player_desktop_runtime:30.0.0.113
    cpe:2.3:a:adobe:flash_player_desktop_runtime:30.0.0.113
  • Apple Mac OS X
    cpe:2.3:o:apple:mac_os_x
  • Linux Kernel
    cpe:2.3:o:linux:linux_kernel
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
  • cpe:2.3:a:adobe:flash_player:30.0.0.113:-:-:-:-:chrome
    cpe:2.3:a:adobe:flash_player:30.0.0.113:-:-:-:-:chrome
  • Apple Mac OS X
    cpe:2.3:o:apple:mac_os_x
  • cpe:2.3:o:google:chrome_os
    cpe:2.3:o:google:chrome_os
  • Linux Kernel
    cpe:2.3:o:linux:linux_kernel
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
  • cpe:2.3:a:adobe:flash_player:30.0.0.113:-:-:-:-:edge
    cpe:2.3:a:adobe:flash_player:30.0.0.113:-:-:-:-:edge
  • cpe:2.3:a:adobe:flash_player:30.0.0.113:-:-:-:-:internet_explorer_11
    cpe:2.3:a:adobe:flash_player:30.0.0.113:-:-:-:-:internet_explorer_11
  • cpe:2.3:o:microsoft:windows_10
    cpe:2.3:o:microsoft:windows_10
  • cpe:2.3:o:microsoft:windows_8.1
    cpe:2.3:o:microsoft:windows_8.1
  • Red Hat Enterprise Linux Desktop 6.0
    cpe:2.3:o:redhat:enterprise_linux_desktop:6.0
  • Red Hat Enterprise Linux Server 6.0
    cpe:2.3:o:redhat:enterprise_linux_server:6.0
  • Red Hat Enterprise Linux Workstation 6.0
    cpe:2.3:o:redhat:enterprise_linux_workstation:6.0
CVSS
Base: 5.0
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
nessus via4
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2018-2175.NASL
    description An update for flash-plugin is now available for Red Hat Enterprise Linux 6 Supplementary. Red Hat Product Security has rated this update as having a security impact of Critical. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section. The flash-plugin package contains a Mozilla Firefox compatible Adobe Flash Player web browser plug-in. This update upgrades Flash Player to version 30.0.0.134. Security Fix(es) : * flash-plugin: Arbitrary Code Execution vulnerability (APSB18-24) (CVE-2018-5007) * flash-plugin: Information Disclosure vulnerability (APSB18-24) (CVE-2018-5008) For more details about the security issue(s), including the impact, a CVSS score, and other related information, refer to the CVE page(s) listed in the References section.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 111032
    published 2018-07-12
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=111032
    title RHEL 6 : flash-plugin (RHSA-2018:2175)
  • NASL family Windows : Microsoft Bulletins
    NASL id SMB_NT_MS18_JUL_4338832.NASL
    description The remote Windows host is missing security update KB4338832. It is, therefore, affected by multiple remote code execution vulnerabilities in Adobe Flash Player.
    last seen 2019-02-21
    modified 2018-08-16
    plugin id 110988
    published 2018-07-10
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=110988
    title KB4338832: Security update for Adobe Flash Player (July 2018)
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_FLASH_PLAYER_APSB18-24.NASL
    description The version of Adobe Flash Player installed on the remote macOS or Mac OS X host is equal or prior to version 30.0.0.113. It is therefore affected by multiple vulnerabilities.
    last seen 2019-02-21
    modified 2018-08-16
    plugin id 110977
    published 2018-07-10
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=110977
    title Adobe Flash Player for Mac <= 30.0.0.113 (APSB18-24)
  • NASL family Windows
    NASL id FLASH_PLAYER_APSB18-24.NASL
    description The version of Adobe Flash Player installed on the remote Windows host is equal or prior to version 30.0.0.113. It is therefore affected by multiple vulnerabilities.
    last seen 2019-02-21
    modified 2018-08-16
    plugin id 110979
    published 2018-07-10
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=110979
    title Adobe Flash Player <= 30.0.0.113 (APSB18-24)
  • NASL family FreeBSD Local Security Checks
    NASL id FREEBSD_PKG_E78732B2852811E89C426451062F0F7A.NASL
    description Adobe reports : - This update resolves an out-of-bounds read vulnerability that could lead to information disclosure (CVE-2018-5008). - This update resolves a type confusion vulnerability that could lead to arbitrary code execution (CVE-2018-5007).
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 111020
    published 2018-07-12
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=111020
    title FreeBSD : Flash Player -- multiple vulnerabilities (e78732b2-8528-11e8-9c42-6451062f0f7a)
redhat via4
advisories
rhsa
id RHSA-2018:2175
refmap via4
bid 104698
confirm https://helpx.adobe.com/security/products/flash-player/apsb18-24.html
sectrack 1041248
Last major update 20-07-2018 - 15:29
Published 20-07-2018 - 15:29
Last modified 17-09-2018 - 13:23
Back to Top