ID CVE-2017-5340
Summary Zend/zend_hash.c in PHP before 7.0.15 and 7.1.x before 7.1.1 mishandles certain cases that require large array allocations, which allows remote attackers to execute arbitrary code or cause a denial of service (integer overflow, uninitialized memory access, and use of arbitrary destructor function pointers) via crafted serialized data.
References
Vulnerable Configurations
  • cpe:2.3:a:php:php:7.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.5:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.5:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.6:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.6:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.7:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.7:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.8:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.8:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.9:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.9:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.10:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.10:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.11:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.11:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.12:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.12:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.13:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.13:*:*:*:*:*:*:*
  • cpe:2.3:a:php:php:7.0.14:*:*:*:*:*:*:*
    cpe:2.3:a:php:php:7.0.14:*:*:*:*:*:*:*
CVSS
Base: 7.5 (as of 04-05-2018 - 01:29)
Impact:
Exploitability:
CWE CWE-190
CAPEC
  • Forced Integer Overflow
    This attack forces an integer variable to go out of range. The integer variable is often used as an offset such as size of memory allocation or similarly. The attacker would typically control the value of such variable and try to get it out of range. For instance the integer in question is incremented past the maximum possible value, it may wrap to become a very small, or negative number, therefore providing a very incorrect value which can lead to unexpected behavior. At worst the attacker can execute arbitrary code.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:P/I:P/A:P
redhat via4
advisories
rhsa
id RHSA-2018:1296
refmap via4
bid 95371
confirm
sectrack 1037659
Last major update 04-05-2018 - 01:29
Published 11-01-2017 - 06:59
Back to Top