ID CVE-2017-3059
Summary Adobe Flash Player versions 25.0.0.127 and earlier have an exploitable use after free vulnerability in the internal script object. Successful exploitation could lead to arbitrary code execution.
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:flash_player:25.0.0.127:-:-:-:-:edge
    cpe:2.3:a:adobe:flash_player:25.0.0.127:-:-:-:-:edge
  • cpe:2.3:a:adobe:flash_player:25.0.0.127:-:-:-:-:internet_explorer
    cpe:2.3:a:adobe:flash_player:25.0.0.127:-:-:-:-:internet_explorer
  • cpe:2.3:o:microsoft:windows_10
    cpe:2.3:o:microsoft:windows_10
  • cpe:2.3:o:microsoft:windows_8.1
    cpe:2.3:o:microsoft:windows_8.1
  • cpe:2.3:a:adobe:flash_player:25.0.0.127:-:-:-:-:chrome
    cpe:2.3:a:adobe:flash_player:25.0.0.127:-:-:-:-:chrome
  • Apple Mac OS X
    cpe:2.3:o:apple:mac_os_x
  • cpe:2.3:o:google:chrome_os
    cpe:2.3:o:google:chrome_os
  • Linux Kernel
    cpe:2.3:o:linux:linux_kernel
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
  • cpe:2.3:a:adobe:flash_player:25.0.0.127
    cpe:2.3:a:adobe:flash_player:25.0.0.127
  • Apple Mac OS X
    cpe:2.3:o:apple:mac_os_x
  • Linux Kernel
    cpe:2.3:o:linux:linux_kernel
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
CVSS
Base: 10.0 (as of 18-04-2017 - 10:57)
Impact:
Exploitability:
CWE CWE-416
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
nessus via4
  • NASL family SuSE Local Security Checks
    NASL id SUSE_SU-2017-0990-1.NASL
    description Adobe flash-player was updated to 25.0.0.148 to fix the following issues : - Vulnerabilities fixed as advised under APSB17-10 : - Use-after-free vulnerabilities that could lead to code execution (CVE-2017-3058, CVE-2017-3059, CVE-2017-3062, CVE-2017-3063). - Resolve memory corruption vulnerabilities that could lead to code execution (CVE-2017-3060, CVE-2017-3061, CVE-2017-3064). - Details: https://helpx.adobe.com/security/products/flash-player/a psb17-10.html Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-01-16
    modified 2018-11-30
    plugin id 99355
    published 2017-04-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=99355
    title SUSE SLED12 Security Update : flash-player (SUSE-SU-2017:0990-1)
  • NASL family Windows : Microsoft Bulletins
    NASL id SMB_NT_MS17_APR_4018483.NASL
    description The remote Windows host is missing security update KB4018483. It is, therefore, affected by multiple vulnerabilities : - Multiple use-after-free errors exist that allow an unauthenticated, remote attacker to - execute arbitrary code. (CVE-2017-3058, CVE-2017-3059, CVE-2017-3062, CVE-2017-3063) - Multiple memory corruption issues exist that allow an unauthenticated, remote attacker to execute arbitrary code. (CVE-2017-3060, CVE-2017-3061, CVE-2017-3064)
    last seen 2019-01-16
    modified 2018-08-03
    plugin id 99290
    published 2017-04-11
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=99290
    title KB4018483: Security update for Adobe Flash Player (April 2017)
  • NASL family Windows
    NASL id FLASH_PLAYER_APSB17-10.NASL
    description The version of Adobe Flash Player installed on the remote Windows host is equal or prior to version 25.0.0.127. It is, therefore, affected by multiple vulnerabilities : - Multiple use-after-free errors exist that allow an unauthenticated, remote attacker to execute arbitrary code. (CVE-2017-3058, CVE-2017-3059, CVE-2017-3062, CVE-2017-3063) - Multiple memory corruption issues exist that allow an unauthenticated, remote attacker to execute arbitrary code. (CVE-2017-3060, CVE-2017-3061, CVE-2017-3064)
    last seen 2019-01-16
    modified 2018-07-11
    plugin id 99283
    published 2017-04-11
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=99283
    title Adobe Flash Player <= 25.0.0.127 Multiple Vulnerabilities (APSB17-10)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2017-0934.NASL
    description An update for flash-plugin is now available for Red Hat Enterprise Linux 6 Supplementary. Red Hat Product Security has rated this update as having a security impact of Critical. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section. The flash-plugin package contains a Mozilla Firefox compatible Adobe Flash Player web browser plug-in. This update upgrades Flash Player to version 25.0.0.148. Security Fix(es) : * This update fixes multiple vulnerabilities in Adobe Flash Player. These vulnerabilities, detailed in the Adobe Security Bulletin listed in the References section, could allow an attacker to create a specially crafted SWF file that would cause flash-plugin to crash, execute arbitrary code, or disclose sensitive information when the victim loaded a page containing the malicious SWF content. (CVE-2017-3058, CVE-2017-3059, CVE-2017-3060, CVE-2017-3061, CVE-2017-3062, CVE-2017-3063, CVE-2017-3064)
    last seen 2019-01-16
    modified 2018-11-10
    plugin id 99347
    published 2017-04-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=99347
    title RHEL 6 : flash-plugin (RHSA-2017:0934)
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_FLASH_PLAYER_APSB17-10.NASL
    description The version of Adobe Flash Player installed on the remote macOS or Mac OS X host is equal or prior to version 25.0.0.127. It is, therefore, affected by multiple vulnerabilities : - Multiple use-after-free errors exist that allow an unauthenticated, remote attacker to execute arbitrary code. (CVE-2017-3058, CVE-2017-3059, CVE-2017-3062, CVE-2017-3063) - Multiple memory corruption issues exist that allow an unauthenticated, remote attacker to execute arbitrary code. (CVE-2017-3060, CVE-2017-3061, CVE-2017-3064)
    last seen 2019-01-16
    modified 2018-07-14
    plugin id 99284
    published 2017-04-11
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=99284
    title Adobe Flash Player for Mac <= 25.0.0.127 Multiple Vulnerabilities (APSB17-10)
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-201704-04.NASL
    description The remote host is affected by the vulnerability described in GLSA-201704-04 (Adobe Flash Player: Multiple vulnerabilities) Multiple vulnerabilities have been discovered in Adobe Flash Player. Please review the CVE identifiers referenced below for details. Impact : A remote attacker could possibly execute arbitrary code with the privileges of the process or bypass security restrictions. Workaround : There is no known workaround at this time.
    last seen 2019-01-16
    modified 2018-01-26
    plugin id 99699
    published 2017-04-27
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=99699
    title GLSA-201704-04 : Adobe Flash Player: Multiple vulnerabilities
redhat via4
advisories
rhsa
id RHSA-2017:0934
refmap via4
bid 97551
confirm https://helpx.adobe.com/security/products/flash-player/apsb17-10.html
gentoo GLSA-201704-04
sectrack 1038225
Last major update 18-04-2017 - 16:49
Published 12-04-2017 - 10:59
Last modified 04-01-2018 - 21:31
Back to Top