ID CVE-2017-14139
Summary ImageMagick 7.0.6-2 has a memory leak vulnerability in WriteMSLImage in coders/msl.c.
References
Vulnerable Configurations
  • cpe:2.3:a:imagemagick:imagemagick:7.0.6-2:*:*:*:*:*:*:*
    cpe:2.3:a:imagemagick:imagemagick:7.0.6-2:*:*:*:*:*:*:*
CVSS
Base: 4.3 (as of 03-10-2019 - 00:03)
Impact:
Exploitability:
CWE CWE-772
CAPEC
  • HTTP DoS
    An attacker performs flooding at the HTTP level to bring down only a particular web application rather than anything listening on a TCP/IP connection. This denial of service attack requires substantially fewer packets to be sent which makes DoS harder to detect. This is an equivalent of SYN flood in HTTP. The idea is to keep the HTTP session alive indefinitely and then repeat that hundreds of times. This attack targets resource depletion weaknesses in web server software. The web server will wait to attacker's responses on the initiated HTTP sessions while the connection threads are being exhausted.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
assigner via4 cve@mitre.org
cvss-vector via4 AV:N/AC:M/Au:N/C:N/I:N/A:P
refmap via4
confirm https://github.com/ImageMagick/ImageMagick/issues/578
gentoo GLSA-201711-07
vulnerable_product via4 cpe:2.3:a:imagemagick:imagemagick:7.0.6-2:*:*:*:*:*:*:*
Last major update 03-10-2019 - 00:03
Published 04-09-2017 - 23:29
Back to Top