ID CVE-2017-12904
Summary Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.
References
Vulnerable Configurations
  • cpe:2.3:a:newsbeuter:newsbeuter:0.7:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:0.7:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:0.8:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:0.8:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:0.8.1:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:0.8.1:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:0.8.2:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:0.8.2:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:0.9:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:0.9:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:0.9.1:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:0.9.1:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:1.0:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:1.1:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:1.2:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:1.3:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:1.3:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.0:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.1:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.2:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.2:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.3:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.4:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.4:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.5:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.5:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.6:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.6:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.7:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.7:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.8:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.8:*:*:*:*:*:*:*
  • cpe:2.3:a:newsbeuter:newsbeuter:2.9:*:*:*:*:*:*:*
    cpe:2.3:a:newsbeuter:newsbeuter:2.9:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
CVSS
Base: 9.3 (as of 21-10-2020 - 20:15)
Impact:
Exploitability:
CWE CWE-943
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
cvss-vector via4 AV:N/AC:M/Au:N/C:C/I:C/A:C
refmap via4
confirm
debian DSA-3947
mlist [newsbeuter] 20170817 [CVE-2017-12904] Remote code execution
Last major update 21-10-2020 - 20:15
Published 23-08-2017 - 14:29
Last modified 21-10-2020 - 20:15
Back to Top